summaryrefslogtreecommitdiffstats
path: root/testing/perl-test-simple
diff options
context:
space:
mode:
authorFrancesco Colista <francesco.colista@gmail.com>2012-01-02 09:29:50 +0000
committerFrancesco Colista <francesco.colista@gmail.com>2012-01-02 09:29:50 +0000
commitbf5b7c11e4844cc590c696365d8a8b4c519cd109 (patch)
tree1cc249d0b4d295e54826275db5b9ef567da5d751 /testing/perl-test-simple
parent30e7c8dec95f94259dc416cd113b52c3571f779d (diff)
downloadaports-bf5b7c11e4844cc590c696365d8a8b4c519cd109.tar.bz2
aports-bf5b7c11e4844cc590c696365d8a8b4c519cd109.tar.xz
testing/perl-test-simple: new apkbuild
Diffstat (limited to 'testing/perl-test-simple')
-rw-r--r--testing/perl-test-simple/APKBUILD34
1 files changed, 20 insertions, 14 deletions
diff --git a/testing/perl-test-simple/APKBUILD b/testing/perl-test-simple/APKBUILD
index 8122e47de..a046693eb 100644
--- a/testing/perl-test-simple/APKBUILD
+++ b/testing/perl-test-simple/APKBUILD
@@ -1,25 +1,31 @@
-# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
-# Maintainer:
+# Automatically generated by apkbuild-cpan, template 1
+# Contributor: Francesco Colista <francesco.colista@gmail.com>
+# Maintainer: Francesco Colista <francesco.colista@gmail.com>
pkgname=perl-test-simple
-_realname=Test-Simple
+_pkgreal=Test-Simple
pkgver=0.98
pkgrel=0
-pkgdesc="Perl modules for writing tests"
-url="http://search.cpan.org/~mschwern/Test-Simple-0.98/"
+pkgdesc="Basic utilities for writing tests."
+url="http://search.cpan.org/dist/Test-Simple/"
arch="noarch"
-license="PerlArtistic"
-depends="perl"
-depends_dev=""
-makedepends="perl-dev"
-install=""
+license="GPL PerlArtistic"
+cpandepends=""
+cpanmakedepends=""
+depends="$cpandepends"
+makedepends="perl-dev $cpanmakedepends"
subpackages="$pkgname-doc"
-source="http://search.cpan.org/CPAN/authors/id/M/MS/MSCHWERN/$_realname-$pkgver.tar.gz"
-_builddir="$srcdir"/$_realname-$pkgver
+source="http://search.cpan.org/CPAN/authors/id/M/MS/MSCHWERN/$_pkgreal-$pkgver.tar.gz"
+
+_builddir="$srcdir/$_pkgreal-$pkgver"
+
+prepare() {
+ cd "$_builddir"
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+}
build() {
cd "$_builddir"
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
- make || return 1
+ make && make test
}
package() {