summaryrefslogtreecommitdiffstats
path: root/testing/perl-uri-find-simple
diff options
context:
space:
mode:
authorKiyoshi Aman <aphrael@alpinelinux.org>2011-12-01 08:38:22 -0500
committerKiyoshi Aman <aphrael@alpinelinux.org>2011-12-04 22:09:38 -0500
commit84d5e8942816778dc609d92eb6e6377cf9b33faa (patch)
tree9eb00185166655a6a23293fd78c8089615239ddf /testing/perl-uri-find-simple
parent54d1606e0023192b0f09d5265d5cb948e2d18b27 (diff)
downloadaports-84d5e8942816778dc609d92eb6e6377cf9b33faa.tar.bz2
aports-84d5e8942816778dc609d92eb6e6377cf9b33faa.tar.xz
testing/perl-uri-find-simple: new APKBUILD
Diffstat (limited to 'testing/perl-uri-find-simple')
-rw-r--r--testing/perl-uri-find-simple/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/testing/perl-uri-find-simple/APKBUILD b/testing/perl-uri-find-simple/APKBUILD
new file mode 100644
index 000000000..c34a90160
--- /dev/null
+++ b/testing/perl-uri-find-simple/APKBUILD
@@ -0,0 +1,37 @@
+# Automatically generated by apkbuild-cpan, template 1
+# Contributor: Kiyoshi Aman <kiyoshi.aman@gmail.com>
+# Maintainer: Kiyoshi Aman <kiyoshi.aman@gmail.com>
+pkgname=perl-uri-find-simple
+_pkgreal=URI-Find-Simple
+pkgver=1.03
+pkgrel=0
+pkgdesc="unknown"
+url="http://search.cpan.org/dist/URI-Find-Simple/"
+arch="noarch"
+license="GPL PerlArtistic"
+cpandepends="perl-uri-find"
+cpanmakedepends=""
+depends="$cpandepends"
+makedepends="perl-dev $cpanmakedepends"
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/T/TO/TOMI/$_pkgreal-$pkgver.tar.gz"
+
+_builddir="$srcdir/$_pkgreal-$pkgver"
+
+prepare() {
+ cd "$_builddir"
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+}
+
+build() {
+ cd "$_builddir"
+ make && make test
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+md5sums="a3d62887ea6b6a17559364e8a31fcd8f URI-Find-Simple-1.03.tar.gz"