summaryrefslogtreecommitdiffstats
path: root/testing/plymouth
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2011-12-17 02:22:34 -0600
committerWilliam Pitcock <nenolod@dereferenced.org>2011-12-17 02:22:34 -0600
commit697e1ef4ccb48c3e16b8655b99def083be7c057f (patch)
tree49c92f08eecd6140a8c61df74ca59cee99bbc4a0 /testing/plymouth
parent307a51330502cf44c3164e45cc9c5f1675e2887f (diff)
downloadaports-697e1ef4ccb48c3e16b8655b99def083be7c057f.tar.bz2
aports-697e1ef4ccb48c3e16b8655b99def083be7c057f.tar.xz
testing/plymouth: new aport
Diffstat (limited to 'testing/plymouth')
-rw-r--r--testing/plymouth/APKBUILD65
-rw-r--r--testing/plymouth/plymouth-rpmatch.patch17
2 files changed, 82 insertions, 0 deletions
diff --git a/testing/plymouth/APKBUILD b/testing/plymouth/APKBUILD
new file mode 100644
index 000000000..24e6821ee
--- /dev/null
+++ b/testing/plymouth/APKBUILD
@@ -0,0 +1,65 @@
+# Contributor: William Pitcock <nenolod@dereferenced.org>
+# Maintainer: William Pitcock <nenolod@dereferenced.org>
+pkgname=plymouth
+pkgver=0.8.3
+pkgrel=0
+pkgdesc="graphical bootsplash on linux"
+url="http://www.freedesktop.org/wiki/Software/Plymouth"
+arch="all"
+license="GPL"
+depends=""
+depends_dev="pango-dev
+ gtk+-dev
+ libpng-dev
+ libdrm-dev"
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-dev $pkgname-doc $pkgname-x11 $pkgname-log-viewer:logviewer"
+source="http://www.freedesktop.org/software/plymouth/releases/plymouth-$pkgver.tar.bz2
+ plymouth-rpmatch.patch"
+
+_builddir="$srcdir"/plymouth-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ --with-system-root-install \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+
+ rm -f "$pkgdir"/lib/*.la
+ rm -f "$pkgdir"/usr/lib/*.la
+ rm -f "$pkgdir"/usr/lib/plymouth/*.la
+ rm -f "$pkgdir"/usr/lib/plymouth/renderers/*.la
+}
+
+x11() {
+ mkdir -p "$subpkgdir"/usr/lib/plymouth/renderers
+ mv "$pkgdir"/usr/lib/plymouth/renderers/x11.so "$subpkgdir"/usr/lib/plymouth/renderers
+}
+
+logviewer() {
+ mkdir -p "$subpkgdir"/usr/bin
+ mv "$pkgdir"/usr/bin/plymouth-log-viewer "$subpkgdir"/usr/bin
+}
+
+md5sums="a479180467b21dd1c5477160d5a1fd35 plymouth-0.8.3.tar.bz2
+7d342aa2f011833647f1c696007b190c plymouth-rpmatch.patch"
diff --git a/testing/plymouth/plymouth-rpmatch.patch b/testing/plymouth/plymouth-rpmatch.patch
new file mode 100644
index 000000000..f6e194874
--- /dev/null
+++ b/testing/plymouth/plymouth-rpmatch.patch
@@ -0,0 +1,17 @@
+--- plymouth-0.8.3.orig/src/libply/ply-command-parser.c
++++ plymouth-0.8.3/src/libply/ply-command-parser.c
+@@ -671,6 +671,14 @@
+ return argument[0] == '-' && argument[1] == '-';
+ }
+
++static inline int
++rpmatch (const char *response)
++{
++ /* Test against "^[yY]" and "^[nN]", hardcoded to avoid requiring regex */
++ return (*response == 'y' || *response == 'Y' ? 1
++ : *response == 'n' || *response == 'N' ? 0 : -1);
++}
++
+ static bool
+ ply_command_option_read_arguments (ply_command_option_t *option,
+ ply_list_t *arguments)