summaryrefslogtreecommitdiffstats
path: root/testing/powertop
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-03-25 20:24:44 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-03-25 20:25:29 +0000
commit9a612f6719f594d0825e1cca0b6d5f3bc46db9ae (patch)
tree350f0d6797d02694e895736c69cbe5ff36548489 /testing/powertop
parentbc05eaa2ff8bd0519a2395f81cd25a5807aa0217 (diff)
downloadaports-9a612f6719f594d0825e1cca0b6d5f3bc46db9ae.tar.bz2
aports-9a612f6719f594d0825e1cca0b6d5f3bc46db9ae.tar.xz
testing/powertop: new aport
Diffstat (limited to 'testing/powertop')
-rw-r--r--testing/powertop/APKBUILD40
-rw-r--r--testing/powertop/intl.patch11
2 files changed, 51 insertions, 0 deletions
diff --git a/testing/powertop/APKBUILD b/testing/powertop/APKBUILD
new file mode 100644
index 000000000..3cf4ec8d2
--- /dev/null
+++ b/testing/powertop/APKBUILD
@@ -0,0 +1,40 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=powertop
+pkgver=1.97
+pkgrel=0
+pkgdesc="Power consumption monitor"
+url="http://www.lesswatts.org/"
+arch="all"
+license="GPLv2"
+depends=
+makedepends="ncurses-dev pciutils-dev zlib-dev libnl-dev gettext-dev"
+install=""
+subpackages=
+source="http://www.kernel.org/pub/linux/status/powertop/powertop-$pkgver.tar.bz2
+ intl.patch"
+
+_builddir="$srcdir"/powertop-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+ rm -f po/nl.po
+}
+
+build() {
+ cd "$_builddir"
+ make FLAGS="$CFLAGS" || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="ddd318fe930c86b3666cad6f40b661bc powertop-1.97.tar.bz2
+2f04368b889cf5ef679bed7d1517857b intl.patch"
diff --git a/testing/powertop/intl.patch b/testing/powertop/intl.patch
new file mode 100644
index 000000000..d88039fc7
--- /dev/null
+++ b/testing/powertop/intl.patch
@@ -0,0 +1,11 @@
+--- ./Makefile.orig
++++ ./Makefile
+@@ -48,7 +48,7 @@
+ # ncurses-devel and pciutils-devel
+ #
+
+-LIBS += -lpthread -lncursesw -lpci -lz -lresolv
++LIBS += -lpthread -lncursesw -lpci -lz -lresolv -lintl
+
+ HEADERS := cpu/cpu.h
+