summaryrefslogtreecommitdiffstats
path: root/testing/py-beautifulsoup
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2012-05-24 18:50:30 +0000
committerFabian Affolter <fabian@affolter-engineering.ch>2012-05-25 19:36:34 +0000
commit354f48716a6505d96e51c8827523cde2fc1ba62c (patch)
tree22546a156bcf1b1c51078576aefb9709388d3378 /testing/py-beautifulsoup
parent867fe3121755e7c557cf6b7740b2817fce982d16 (diff)
downloadaports-354f48716a6505d96e51c8827523cde2fc1ba62c.tar.bz2
aports-354f48716a6505d96e51c8827523cde2fc1ba62c.tar.xz
testing/py-beautifulsoup: minor layout changes
Diffstat (limited to 'testing/py-beautifulsoup')
-rw-r--r--testing/py-beautifulsoup/APKBUILD11
1 files changed, 9 insertions, 2 deletions
diff --git a/testing/py-beautifulsoup/APKBUILD b/testing/py-beautifulsoup/APKBUILD
index fa8bb7c9e..5cb0d4068 100644
--- a/testing/py-beautifulsoup/APKBUILD
+++ b/testing/py-beautifulsoup/APKBUILD
@@ -8,15 +8,22 @@ pkgdesc="A Python HTML/XML parser designed for quick turnaround projects like sc
url="http://www.crummy.com/software/BeautifulSoup/index.html"
arch="noarch"
license="BSD"
-depends=
+depends=""
depends_dev="python-dev"
makedepends="$depends_dev"
install=""
subpackages=""
source="http://www.crummy.com/software/BeautifulSoup/download/3.x/$_pkgname-$pkgver.tar.gz"
+
_builddir="$srcdir"/$_pkgname-$pkgver
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
package() {
cd "$_builddir"
- python setup.py install --root=$pkgdir
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
}
+
md5sums="5ad1a8550a19bfc945baac23eb8293ed BeautifulSoup-3.2.1.tar.gz"