summaryrefslogtreecommitdiffstats
path: root/testing/py-crypto
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-05-21 12:05:25 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-05-21 12:05:25 +0000
commit0411e8673b6610316fabfac56795927ecc02c399 (patch)
tree08294cf243cbcc428f7db7ebfddd04e8a150b5a8 /testing/py-crypto
parent6ded59b0e00bc55688693e1393267e8447a400e0 (diff)
downloadaports-0411e8673b6610316fabfac56795927ecc02c399.tar.bz2
aports-0411e8673b6610316fabfac56795927ecc02c399.tar.xz
main/busybox: add patches from upstream
Diffstat (limited to 'testing/py-crypto')
-rw-r--r--testing/py-crypto/APKBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/testing/py-crypto/APKBUILD b/testing/py-crypto/APKBUILD
new file mode 100644
index 000000000..75f31dd65
--- /dev/null
+++ b/testing/py-crypto/APKBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=py-crypto
+pkgver=2.0.1
+pkgrel=2
+pkgdesc="A collection of cryptographic algorithms and protocols, implemented for use from Python."
+url="http://www.amk.ca/python/code/crypto.html"
+license="GPL"
+depends="python"
+makedepends="gmp5-dev python-dev"
+source="http://www.amk.ca/files/python/crypto/pycrypto-$pkgver.tar.gz"
+
+_builddir="$srcdir"/pycrypto-$pkgver
+build ()
+{
+ cd "$_builddir"
+ python setup.py build
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --root="$pkgdir"
+}
+md5sums="4d5674f3898a573691ffb335e8d749cd pycrypto-2.0.1.tar.gz"