summaryrefslogtreecommitdiffstats
path: root/testing/py-futures
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2012-01-30 03:12:50 +0000
committerFabian Affolter <fabian@affolter-engineering.ch>2012-05-17 13:32:36 +0000
commit38b55c687038ef865a411f734b643b79bed5a368 (patch)
tree16a35e01f00a3d5446251d6f9c292424d652988f /testing/py-futures
parent94454b138f9449c9c252812054bdd633c6a64f8e (diff)
downloadaports-38b55c687038ef865a411f734b643b79bed5a368.tar.bz2
aports-38b55c687038ef865a411f734b643b79bed5a368.tar.xz
testing/py-futures: new aport
Backport of the concurrent.futures package from Python 3.2 http://code.google.com/p/pythonfutures/
Diffstat (limited to 'testing/py-futures')
-rw-r--r--testing/py-futures/APKBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/testing/py-futures/APKBUILD b/testing/py-futures/APKBUILD
new file mode 100644
index 000000000..290065519
--- /dev/null
+++ b/testing/py-futures/APKBUILD
@@ -0,0 +1,39 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-futures
+_pkgname=futures
+pkgver=2.1.2
+pkgrel=0
+pkgdesc="Backport of the concurrent.futures package from Python 3.2"
+url="http://code.google.com/p/pythonfutures/"
+arch="noarch"
+license="BSD"
+depends="python"
+depends_dev=""
+makedepends="python-dev"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/f/$_pkgname/$_pkgname-$pkgver.tar.gz"
+_builddir="$srcdir"/$_pkgname-$pkgver
+
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="a6fa247e3c5fe3d60d8e12f1b873cc88 futures-2.1.2.tar.gz"