summaryrefslogtreecommitdiffstats
path: root/testing/py-libacl
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2011-10-08 15:46:44 +0000
committerWilliam Pitcock <nenolod@dereferenced.org>2011-12-03 14:49:17 -0600
commit7e4aa4b8a16a229eec21bfbe518baf5deae9c613 (patch)
tree04bd2a674942fdb3635ac8889a1c87cffa592d9a /testing/py-libacl
parentbdf4291c9f0218b680d4f1579fcaee3e6bd6b81d (diff)
downloadaports-7e4aa4b8a16a229eec21bfbe518baf5deae9c613.tar.bz2
aports-7e4aa4b8a16a229eec21bfbe518baf5deae9c613.tar.xz
Initial APKBUILD for pylibacl
Package description: This module provides support for manipulating POSIX.1e ACLS Depending on the operating system support for POSIX.1e, the ACL type will have more or less capabilities: - level 1, only basic support, you can create ACLs from files and text descriptions; once created, the type is immutable - level 2, complete support, you can alter the ACL once it is created Also, in level 2, more types are available, corresponding to acl_entry_t (the Entry type), acl_permset_t (the Permset type). The existence of level 2 support and other extensions can be checked by the constants: - HAS_ACL_ENTRY for level 2 and the Entry/Permset classes - HAS_ACL_FROM_MODE for ACL(mode=...) usage - HAS_ACL_CHECK for the ACL().check function - HAS_EXTENDED_CHECK for the module-level has_extended function - HAS_EQUIV_MODE for the ACL().equiv_mode method
Diffstat (limited to 'testing/py-libacl')
-rw-r--r--testing/py-libacl/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/testing/py-libacl/APKBUILD b/testing/py-libacl/APKBUILD
new file mode 100644
index 000000000..975524ea8
--- /dev/null
+++ b/testing/py-libacl/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-libacl
+_pkgname=pylibacl
+pkgver=0.5.0
+pkgrel=0
+pkgdesc="A python module for manipulating ACLs"
+url="http://pylibacl.sourceforge.net/"
+arch="all"
+license="LGPL2+"
+depends=""
+depends_dev=""
+makedepends="python-dev acl-dev py-setuptools"
+install=""
+subpackages=""
+source="http://downloads.sourceforge.net/$_pkgname/$_pkgname-$pkgver.tar.gz"
+_builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --root="$pkgdir" || return 1
+}
+
+md5sums="b9d34da90e6da0813115071b3a1ab204 pylibacl-0.5.0.tar.gz"