summaryrefslogtreecommitdiffstats
path: root/testing/py-m2crypto
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2011-10-02 12:45:08 +0000
committerWilliam Pitcock <nenolod@dereferenced.org>2011-12-03 14:49:17 -0600
commitbdf4291c9f0218b680d4f1579fcaee3e6bd6b81d (patch)
tree2e7ef167f45817937637a6651b0f6921a2d844ec /testing/py-m2crypto
parent4c2734224b63d9d1f462f622cfd8acba03fbd34e (diff)
downloadaports-bdf4291c9f0218b680d4f1579fcaee3e6bd6b81d.tar.bz2
aports-bdf4291c9f0218b680d4f1579fcaee3e6bd6b81d.tar.xz
Initial APKBUILD for py-m2crypto
Package description: M2Crypto is the most complete Python wrapper for OpenSSL featuring RSA, DSA, DH, HMACs, message digests, symmetric ciphers (including AES); SSL functionality to implement clients and servers; HTTPS extensions to Python's httplib, urllib, and xmlrpclib; unforgeable HMAC'ing AuthCookies for web session management; FTP/TLS client and server; S/MIME; ZServerSSL: A HTTPS server for Zope and ZSmime: An S/MIME messenger for Zope. M2Crypto can also be used to provide SSL for Twisted.
Diffstat (limited to 'testing/py-m2crypto')
-rw-r--r--testing/py-m2crypto/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/testing/py-m2crypto/APKBUILD b/testing/py-m2crypto/APKBUILD
new file mode 100644
index 000000000..4719b4e0e
--- /dev/null
+++ b/testing/py-m2crypto/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer:
+pkgname=py-m2crypto
+_pkgname=M2Crypto
+pkgver=0.21.1
+pkgrel=0
+pkgdesc="A crypto and SSL toolkit for Python"
+url="http://chandlerproject.org/bin/view/Projects/MeTooCrypto"
+arch="all"
+license="BSD"
+depends=""
+depends_dev=
+makedepends="python-dev swig openssl-dev"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/M/$_pkgname/$_pkgname-$pkgver.tar.gz"
+_builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+md5sums="f93d8462ff7646397a9f77a2fe602d17 M2Crypto-0.21.1.tar.gz"