summaryrefslogtreecommitdiffstats
path: root/testing/py-serial
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2011-08-25 20:57:33 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-08-26 17:06:55 +0000
commit2a4f6f35dd10b6525ed507799c9f68cccb65edae (patch)
tree56a9583d98aa1a1dc80a172d781d6c4384a80a91 /testing/py-serial
parent0acc17a151637e91ba812a5a2472c3eedc593483 (diff)
downloadaports-2a4f6f35dd10b6525ed507799c9f68cccb65edae.tar.bz2
aports-2a4f6f35dd10b6525ed507799c9f68cccb65edae.tar.xz
Initial APKBUILD for pyserial
Package description: This module encapsulates the access for the serial port. It provides backends for Python.
Diffstat (limited to 'testing/py-serial')
-rw-r--r--testing/py-serial/APKBUILD52
1 files changed, 52 insertions, 0 deletions
diff --git a/testing/py-serial/APKBUILD b/testing/py-serial/APKBUILD
new file mode 100644
index 000000000..200eab121
--- /dev/null
+++ b/testing/py-serial/APKBUILD
@@ -0,0 +1,52 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-serial
+_realname=pyserial
+pkgver=2.5
+pkgrel=0
+pkgdesc="Python Serial Port Extension"
+url="http://pyserial.sourceforge.net/"
+arch="noarch"
+license="Python"
+depends="python"
+makedepends="python-dev"
+install=""
+subpackages="$pkgname-doc $pkgname-examples"
+source="http://pypi.python.org/packages/source/p/"$_realname"/pyserial-$pkgver.tar.gz"
+_builddir="$srcdir"/$_realname-$pkgver
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+doc() {
+ cd "$_builddir"
+ mkdir -p "$subpkgdir"/usr/share/doc/$pkgname/ || return 1
+ # Documentation files
+ _docs="appendix.rst examples.rst pyparallel.rst pyserial.rst \
+ pyserial_api.rst shortintro.rst"
+ for _doc in $_docs; do
+ mv "$srcdir"/$_realname-$pkgver/documentation/$_doc \
+ "$subpkgdir"/usr/share/doc/$pkgname/$_doc || return 1
+ done
+}
+
+examples() {
+ cd "$_builddir"
+ mkdir -p "$subpkgdir"/usr/share/doc/$pkgname/examples || return 1
+ # Example files
+ _examples="enhancedserial.py miniterm.py rfc2217_server.py scan.py \
+ scanlinux.py tcp_serial_redirect.py port_publisher.py port_publisher.sh"
+ for _example in $_examples; do
+ mv "$srcdir"/$_realname-$pkgver/examples/$_example \
+ "$subpkgdir"/usr/share/doc/$pkgname/examples/$_example || return 1
+ done
+}
+
+md5sums="34340820710239bea2ceca7f43ef8cab pyserial-2.5.tar.gz"