summaryrefslogtreecommitdiffstats
path: root/testing/py-sip
diff options
context:
space:
mode:
authorFrancesco Colista <francesco.colista@gmail.com>2011-06-20 12:00:47 +0000
committerFrancesco Colista <francesco.colista@gmail.com>2011-06-20 12:02:01 +0000
commit9c6e16bb228787c35137e4a5576a5085a9788a10 (patch)
treefee729147f5d9c0ee9189dfad821042b129668cd /testing/py-sip
parent6a3353563b226569a73920d63a1ef672043b21b5 (diff)
downloadaports-9c6e16bb228787c35137e4a5576a5085a9788a10.tar.bz2
aports-9c6e16bb228787c35137e4a5576a5085a9788a10.tar.xz
testing/chmlib podofo py-dateutils py-importlib py-pycountry py-qt py-sip : new aports
Diffstat (limited to 'testing/py-sip')
-rw-r--r--testing/py-sip/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/testing/py-sip/APKBUILD b/testing/py-sip/APKBUILD
new file mode 100644
index 000000000..db13577f2
--- /dev/null
+++ b/testing/py-sip/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Francesco Colista <francesco.colista@gmail.com>
+# Maintainer:
+pkgname=py-sip
+_pkgname=sip
+pkgver=4.12.3
+pkgrel=0
+pkgdesc="A tool that makes it easy to create Python bindings for C and C++ libraries"
+url="http://www.riverbankcomputing.com/software/sip/"
+arch="all"
+license="custom:sip"
+depends=
+depends_dev="python-dev"
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-dev"
+source="http://www.riverbankcomputing.com/static/Downloads/sip4/${_pkgname}-${pkgver}.tar.gz"
+_builddir="$srcdir"/$_pkgname-$pkgver
+build() {
+ cd "$_builddir"
+ python configure.py
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ install -Dm644 LICENSE ${pkgdir}/usr/share/licenses/custom/${pkgname}/LICENSE
+}
+
+md5sums="d0f1fa60494db04b4d115d4c2d92f79e sip-4.12.3.tar.gz"