summaryrefslogtreecommitdiffstats
path: root/testing/py-six/APKBUILD
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2013-01-08 02:58:46 -0600
committerWilliam Pitcock <nenolod@dereferenced.org>2013-01-08 02:58:46 -0600
commit5f81e551c33fb741e184cc7cdf958c15ff5cb51d (patch)
tree4e24a4977c35920430a2c97151fa2c6c387d14e6 /testing/py-six/APKBUILD
parentc2eff4480adba5436fd175387796a20c988b2b9b (diff)
downloadaports-5f81e551c33fb741e184cc7cdf958c15ff5cb51d.tar.bz2
aports-5f81e551c33fb741e184cc7cdf958c15ff5cb51d.tar.xz
testing/py-six: new aport
Diffstat (limited to 'testing/py-six/APKBUILD')
-rw-r--r--testing/py-six/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/testing/py-six/APKBUILD b/testing/py-six/APKBUILD
new file mode 100644
index 000000000..c0a476037
--- /dev/null
+++ b/testing/py-six/APKBUILD
@@ -0,0 +1,38 @@
+# Contributor: William Pitcock <nenolod@dereferenced.org>
+# Maintainer: William Pitcock <nenolod@dereferenced.org>
+pkgname=py-six
+pkgver=1.2.0
+pkgrel=0
+pkgdesc="Python 2 and 3 compatibility library"
+url="http://pypi.python.org/pypi/six"
+arch="noarch"
+license="MIT"
+depends="python"
+depends_dev=""
+makedepends="python-dev"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/s/six/six-$pkgver.tar.gz"
+
+_builddir="$srcdir"/six-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="2a5d1afc79912832ac78fd38e3d75d7e six-1.2.0.tar.gz"