summaryrefslogtreecommitdiffstats
path: root/testing/py-xattr
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2011-10-08 16:13:04 +0000
committerWilliam Pitcock <nenolod@dereferenced.org>2011-12-03 14:49:17 -0600
commitdef7dd32e1570f15787cd1f297459d930849a947 (patch)
tree04808b62ab963b0da3331545685d441d91a8c6b8 /testing/py-xattr
parent7e4aa4b8a16a229eec21bfbe518baf5deae9c613 (diff)
downloadaports-def7dd32e1570f15787cd1f297459d930849a947.tar.bz2
aports-def7dd32e1570f15787cd1f297459d930849a947.tar.xz
Initial APKBUILD for py-xattr
Package description: This module gives access to the extended attributes present in some operating systems/filesystems. You can list attributes, get, set and remove them. The module exposes two sets of functions: - the 'old' listxattr, getxattr, setxattr, removexattr functions which are deprecated since version 0.4 - the new list, get, get_all, set, remove functions which expose a namespace-aware API and simplify a bit the calling model by using keyword arguments
Diffstat (limited to 'testing/py-xattr')
-rw-r--r--testing/py-xattr/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/testing/py-xattr/APKBUILD b/testing/py-xattr/APKBUILD
new file mode 100644
index 000000000..9d0ec5d9d
--- /dev/null
+++ b/testing/py-xattr/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-xattr
+_pkgname=pyxattr
+pkgver=0.5.0
+pkgrel=0
+pkgdesc="A python module for accessing filesystem Extended Attributes"
+url="http://pyxattr.sourceforge.net/"
+arch="all"
+license="LGPL2+"
+depends=""
+depends_dev=""
+makedepends="python-dev attr-dev"
+install=""
+subpackages=""
+source="http://downloads.sourceforge.net/$_pkgname/$_pkgname-$pkgver.tar.gz"
+_builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --root="$pkgdir" || return 1
+}
+
+md5sums="0f7ab1e185087329e40f7de218517c84 pyxattr-0.5.0.tar.gz"