summaryrefslogtreecommitdiffstats
path: root/testing/py-zmq
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2012-05-18 15:04:40 +0000
committerFabian Affolter <fabian@affolter-engineering.ch>2012-05-20 16:57:42 +0000
commit3c7dedf8ccd444c70c7942b35acf69646ecdf8ce (patch)
tree22b05affc27270271fb59a7e604afa4cd354dc0d /testing/py-zmq
parent287a0fe9a7ce91bdbb32e2037b6e375a2fcdd535 (diff)
downloadaports-3c7dedf8ccd444c70c7942b35acf69646ecdf8ce.tar.bz2
aports-3c7dedf8ccd444c70c7942b35acf69646ecdf8ce.tar.xz
testing/py-zmq: new aport
The 0MQ lightweight messaging kernel is a library which extends the standard socket interfaces with features traditionally provided by specialized messaging middle-ware products. 0MQ sockets provide an abstraction of asynchronous message queues, multiple messaging patterns, message filtering (subscriptions), seamless access to multiple transport protocols and more. http://www.zeromq.org/bindings:python
Diffstat (limited to 'testing/py-zmq')
-rw-r--r--testing/py-zmq/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/testing/py-zmq/APKBUILD b/testing/py-zmq/APKBUILD
new file mode 100644
index 000000000..c5426615a
--- /dev/null
+++ b/testing/py-zmq/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-zmq
+_pkgname=pyzmq
+pkgver=2.2.0
+pkgrel=0
+pkgdesc="Python bindings for ZeroMQ"
+url="http://pypi.python.org/pypi/pyzmq"
+arch="all"
+license="LGPL BSD"
+depends=""
+depends_dev=""
+makedepends="python-dev py-setuptools zeromq-dev"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/p/$_pkgname/$_pkgname-$pkgver.tar.gz"
+_builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="100b73973d6fb235b8da6adea403566e pyzmq-2.2.0.tar.gz"