summaryrefslogtreecommitdiffstats
path: root/testing/ranger
diff options
context:
space:
mode:
authorBartłomiej Piotrowski <b@bpiotrowski.pl>2012-07-12 15:17:03 +0200
committerBartłomiej Piotrowski <b@bpiotrowski.pl>2012-07-12 17:51:52 +0200
commit61cd934e27295286d2b45d46338150f81705954d (patch)
tree2156081a68b7abb189461167f5c3f851a3e54171 /testing/ranger
parent348dff0e529b2ddbaf277689747316ce697098b7 (diff)
downloadaports-61cd934e27295286d2b45d46338150f81705954d.tar.bz2
aports-61cd934e27295286d2b45d46338150f81705954d.tar.xz
testing/ranger: new aport
Diffstat (limited to 'testing/ranger')
-rw-r--r--testing/ranger/APKBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/testing/ranger/APKBUILD b/testing/ranger/APKBUILD
new file mode 100644
index 000000000..85a68183e
--- /dev/null
+++ b/testing/ranger/APKBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Bartłomiej Piotrowski <nospam@bpiotrowski.pl>
+
+pkgname=ranger
+pkgver=1.5.4
+pkgrel=0
+pkgdesc='A simple, vim-like file manager'
+url='http://ranger.nongnu.org'
+arch='any'
+license='GPL'
+depends='python'
+subpackages="$pkgname-doc"
+source="http://ranger.nongnu.org/${pkgname}-${pkgver}.tar.gz"
+
+build() {
+ return 0
+}
+
+package() {
+ cd "$srcdir"/$pkgname-$pkgver
+ python setup.py -q install --root="${pkgdir}" --optimize=1 || return 1
+}
+
+md5sums="1fbc629b7a2c7e3e4695fb218eed7240 ranger-1.5.4.tar.gz"