summaryrefslogtreecommitdiffstats
path: root/testing/scanssh/APKBUILD
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2011-07-03 10:06:55 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-07-03 19:10:41 +0000
commitbdd18a1500063566f95979e619bc9ba250605109 (patch)
tree8b7e40c16b1ccecae903169208abc7c6fda668a8 /testing/scanssh/APKBUILD
parent43f91b3d133e6937a3de8372f60733d02f3fa065 (diff)
downloadaports-bdd18a1500063566f95979e619bc9ba250605109.tar.bz2
aports-bdd18a1500063566f95979e619bc9ba250605109.tar.xz
Initial APKBUILD for scanssh
Package description: ScanSSH supports scanning a list of addresses and networks for open proxies, SSH protocol servers, Web and SMTP servers. Where possible ScanSSH, displays the version number of the running services. ScanSSH protocol scanner supports random selection of IP addresses from large network ranges and is useful for gathering statistics on the deployment of SSH protocol servers in a company or the Internet as whole.
Diffstat (limited to 'testing/scanssh/APKBUILD')
-rw-r--r--testing/scanssh/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/testing/scanssh/APKBUILD b/testing/scanssh/APKBUILD
new file mode 100644
index 000000000..4b91dfb42
--- /dev/null
+++ b/testing/scanssh/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer:
+pkgname=scanssh
+pkgver=2.1
+pkgrel=0
+pkgdesc="Fast SSH server and open proxy scanner"
+url="http://monkey.org/~provos/scanssh/"
+arch="all"
+license="BSD"
+depends=""
+depends_dev=""
+makedepends="libpcap-dev libevent-dev libdnet-dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://monkey.org/~provos/$pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="9fab4253b56b2d15367d4872b370cdcb scanssh-2.1.tar.gz"