summaryrefslogtreecommitdiffstats
path: root/testing/shed
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2011-11-27 11:41:26 +0000
committerWilliam Pitcock <nenolod@dereferenced.org>2011-12-03 14:49:16 -0600
commit5e7c03dfb89244a9fb3690b947149d58efe35314 (patch)
treed2ec64abb67077c13f5496a66d2fd649f084f23a /testing/shed
parentf52aea8509e2b6e794e1232ca0dfeace65e00569 (diff)
downloadaports-5e7c03dfb89244a9fb3690b947149d58efe35314.tar.bz2
aports-5e7c03dfb89244a9fb3690b947149d58efe35314.tar.xz
Initial APKBUILD for shed
Package description: shed is an easy to use hex editor written for unix/linux using ncurses, with a friendly pico-style interface. - Displays each byte as ascii, hex, decimal, octal and binary. - Allows changes to be input in all of the above (and now with bit toggling in the binary column) - Simple Pico-style interface - Search - Dump to file - Small memory requirments because file is not loaded into memory - Large file support Website: http://shed.sourceforge.net/
Diffstat (limited to 'testing/shed')
-rw-r--r--testing/shed/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/testing/shed/APKBUILD b/testing/shed/APKBUILD
new file mode 100644
index 000000000..e159abe88
--- /dev/null
+++ b/testing/shed/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=shed
+pkgver=1.15
+pkgrel=0
+pkgdesc="A simple hex editor"
+url="http://shed.sourceforge.net/"
+arch="all"
+license="GPL2+"
+depends=""
+depends_dev=""
+makedepends="ncurses-dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://downloads.sourceforge.net/shed/shed-$pkgver.tar.gz"
+_builddir="$srcdir"/$pkgname-$pkgver
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ rm -f "$pkgdir"/usr/lib/*.la
+}
+
+md5sums="c7d7d464d6b4fa28a7980270d03e0906 shed-1.15.tar.gz"