summaryrefslogtreecommitdiffstats
path: root/testing/spice-gtk
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-12-18 10:00:26 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-12-18 10:00:26 +0000
commit5c1ef1a5585888bff525a4d89eeb7f4bf8c29e45 (patch)
tree670462f5c61bb1cc4f0e9f98559c48a686381903 /testing/spice-gtk
parente973736b6bd85ddfd19082d577326ddbc40652da (diff)
downloadaports-5c1ef1a5585888bff525a4d89eeb7f4bf8c29e45.tar.bz2
aports-5c1ef1a5585888bff525a4d89eeb7f4bf8c29e45.tar.xz
main/spice-gtk: rebuidl against new usbredir
Diffstat (limited to 'testing/spice-gtk')
-rw-r--r--testing/spice-gtk/APKBUILD9
-rw-r--r--testing/spice-gtk/usbredir.patch52
2 files changed, 59 insertions, 2 deletions
diff --git a/testing/spice-gtk/APKBUILD b/testing/spice-gtk/APKBUILD
index db2ca11f5..123129c43 100644
--- a/testing/spice-gtk/APKBUILD
+++ b/testing/spice-gtk/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=spice-gtk
pkgver=0.14
-pkgrel=0
+pkgrel=1
pkgdesc="A GTK+ widget for SPICE clients"
url="http://spice-space.org/page/Spice-Gtk"
arch="all"
@@ -12,12 +12,15 @@ depends_dev="gtk+2.0-dev celt051-dev polkit-dev libxrandr-dev openssl-dev
cyrus-sasl-dev gst-plugins-base-dev jpeg-dev zlib-dev"
makedepends="$depends_dev bash usbutils py-gtk-dev python-dev udev-dev
usbredir-dev
- polkit-dev py-parsing py-gobject-dev gobject-introspection-dev"
+ polkit-dev py-parsing py-gobject-dev gobject-introspection-dev
+ automake autoconf libtool
+ "
install=""
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang $pkgname-tools
spice-glib:glib py-$pkgname:py"
source="http://www.spice-space.org/download/gtk/spice-gtk-$pkgver.tar.bz2
+ usbredir.patch
codegendir.patch"
_builddir="$srcdir"/spice-gtk-$pkgver
@@ -29,6 +32,7 @@ prepare() {
*.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
esac
done
+ autoreconf
}
build() {
@@ -77,4 +81,5 @@ py() {
}
md5sums="c105e3b7f9c9eb293b0d6a8d35f6a5fd spice-gtk-0.14.tar.bz2
+2f674bfdc70df92df33c8b3ba5e9c0bc usbredir.patch
e267f9505d0be143a308fb3b574fd153 codegendir.patch"
diff --git a/testing/spice-gtk/usbredir.patch b/testing/spice-gtk/usbredir.patch
new file mode 100644
index 000000000..3e926e233
--- /dev/null
+++ b/testing/spice-gtk/usbredir.patch
@@ -0,0 +1,52 @@
+From 6d1505386982aee3622afc1d25f1989965832a55 Mon Sep 17 00:00:00 2001
+From: Hans de Goede <hdegoede@redhat.com>
+Date: Tue, 25 Sep 2012 10:59:13 +0000
+Subject: Deal with libusbredirparser.pc rename to libusbredirparser-0.5.pc
+
+The usbredir 0.5 release introduced the new API for 64 bit packet ids, but
+it kept the libusbredirparser.pc name as is, meaning that older versions of
+qemu will still have their pkg-config check for usbredirparser fulfilled,
+and build with the usb-redir device. Due to the API change there will be
+some compiler warnings, but the build will succeed, however the usb-redir
+device will be broken on 32 bit machines.
+
+To solve this, the usbredir-0.5.2 release renames the libusbredirparser.pc
+file to libusbredirparser-0.5.pc, so that it will no longer fulfill the
+pkg-config check of the qemu-1.2 and older releases, stopping the (silent)
+breakage.
+
+spice-gtk does not use the changed parts of the API, but does
+use libusbredirparser for the usbredirfilter* functions. This patch adapts
+spice-gtk's configure to accept both the libusbredirparser-0.5 and the
+libusbredirparser pkg-config names.
+
+Signed-off-by: Hans de Goede <hdegoede@redhat.com>
+---
+diff --git a/configure.ac b/configure.ac
+index c7367cc..7c59575 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -349,10 +349,17 @@ AC_ARG_ENABLE([usbredir],
+ if test "x$enable_usbredir" = "xno"; then
+ have_usbredir="no"
+ else
+- PKG_CHECK_MODULES([USBREDIR],
+- [libusb-1.0 >= 1.0.9 libusbredirhost >= 0.4.2 libusbredirparser >= 0.4],
+- [have_usbredir=yes],
+- [have_usbredir=no])
++ if ${PKG_CONFIG} libusbredirparser-0.5; then
++ PKG_CHECK_MODULES([USBREDIR],
++ [libusb-1.0 >= 1.0.9 libusbredirhost libusbredirparser-0.5],
++ [have_usbredir=yes],
++ [have_usbredir=no])
++ else
++ PKG_CHECK_MODULES([USBREDIR],
++ [libusb-1.0 >= 1.0.9 libusbredirhost >= 0.4.2 libusbredirparser >= 0.4],
++ [have_usbredir=yes],
++ [have_usbredir=no])
++ fi
+ if test "x$have_usbredir" = "xno" && test "x$enable_usbredir" = "xyes"; then
+ AC_MSG_ERROR([usbredir support explicitly requested, but some required packages are not available])
+ fi
+--
+cgit v0.9.0.2-2-gbebe