summaryrefslogtreecommitdiffstats
path: root/testing/spice-gtk
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-06-18 14:32:53 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-06-18 14:33:15 +0000
commitad31fdffc032e207270c6d28dbf7f54709f438b5 (patch)
treed478efdb7cab7d2c1c5fa7d6b9d9e06a809204f6 /testing/spice-gtk
parent7d59962978a6587fac94aaa69a1ca28290feeef5 (diff)
downloadaports-ad31fdffc032e207270c6d28dbf7f54709f438b5.tar.bz2
aports-ad31fdffc032e207270c6d28dbf7f54709f438b5.tar.xz
testing/spice-gtk: new aport
A GTK+ widget for SPICE clients http://spice-space.org/page/Spice-Gtk
Diffstat (limited to 'testing/spice-gtk')
-rw-r--r--testing/spice-gtk/APKBUILD78
-rw-r--r--testing/spice-gtk/codegendir.patch11
2 files changed, 89 insertions, 0 deletions
diff --git a/testing/spice-gtk/APKBUILD b/testing/spice-gtk/APKBUILD
new file mode 100644
index 000000000..4cfc7ca62
--- /dev/null
+++ b/testing/spice-gtk/APKBUILD
@@ -0,0 +1,78 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=spice-gtk
+pkgver=0.12
+pkgrel=0
+pkgdesc="A GTK+ widget for SPICE clients"
+url="http://spice-space.org/page/Spice-Gtk"
+arch="all"
+license="LGPLv2+"
+depends=""
+depends_dev="gtk+2.0-dev celt051-dev polkit-dev libxrandr-dev openssl-dev
+ cyrus-sasl-dev gst-plugins-base-dev jpeg-dev zlib-dev"
+makedepends="$depends_dev bash usbutils py-gtk-dev python-dev udev-dev
+ polkit-dev py-parsing py-gobject-dev gobject-introspection-dev"
+install=""
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang $pkgname-tools
+ spice-glib:glib py-$pkgname:py"
+
+source="http://www.spice-space.org/download/gtk/spice-gtk-$pkgver.tar.bz2
+ codegendir.patch"
+
+_builddir="$srcdir"/spice-gtk-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --with-gtk=2.0 \
+ --with-audio=gstreamer \
+ --enable-smartcard=no \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make -j1 DESTDIR="$pkgdir" install || return 1
+ rm -f "$pkgdir"/usr/lib/*.la \
+ "$pkgdir"//usr/lib/py*/site-packages/*.la
+}
+
+tools() {
+ pkgdesc=""
+ mkdir -p "$subpkgdir"/usr
+ mv "$pkgdir"/usr/bin "$subpkgdir"/usr/
+}
+
+glib() {
+ pkgdesc=""
+ mkdir -p "$subpkgdir"/usr/lib
+ mv "$pkgdir"/usr/lib/*glib.so* \
+ "$pkgdir"/usr/lib/*controller.so.* \
+ "$subpkgdir"/usr/lib/
+ cd "$pkgdir"
+ for i in $(find -name GLib*.typelib); do
+ mkdir -p "$subpkgdir"/${i%/*}
+ mv $i "$subpkgdir"/${i%/*}
+ done
+}
+
+py() {
+ pkgdsec=""
+ mkdir -p "$subpkgdir"/usr/lib
+ mv "$pkgdir"/usr/lib/python* "$subpkgdir"/usr/lib/
+}
+
+md5sums="2fec0ba391447b5b4d9242455c55b2a3 spice-gtk-0.12.tar.bz2
+e267f9505d0be143a308fb3b574fd153 codegendir.patch"
diff --git a/testing/spice-gtk/codegendir.patch b/testing/spice-gtk/codegendir.patch
new file mode 100644
index 000000000..13b9e4077
--- /dev/null
+++ b/testing/spice-gtk/codegendir.patch
@@ -0,0 +1,11 @@
+--- ./gtk/Makefile.in.orig
++++ ./gtk/Makefile.in
+@@ -895,7 +895,7 @@
+ @WITH_PYTHON_TRUE@SpiceClientGtk_la_LDFLAGS = -module -avoid-version -fPIC
+ @WITH_PYTHON_TRUE@SpiceClientGtk_la_SOURCES = spice-client-gtk-module.c
+ @WITH_PYTHON_TRUE@nodist_SpiceClientGtk_la_SOURCES = spice-client-gtk-module.defs.c
+-@WITH_PYTHON_TRUE@CODEGENDIR = `pkg-config --variable=codegendir pygtk-2.0`
++@WITH_PYTHON_TRUE@CODEGENDIR = `pkg-config --variable=codegendir pygobject-2.0`
+ @WITH_PYTHON_TRUE@DEFSDIR = `pkg-config --variable=defsdir pygtk-2.0`
+ @G_IR_SCANNER_SYMBOL_PREFIX_FALSE@PREFIX_ARGS = --strip-prefix=Spice
+ @G_IR_SCANNER_SYMBOL_PREFIX_TRUE@PREFIX_ARGS = --symbol-prefix=spice --identifier-prefix=Spice