summaryrefslogtreecommitdiffstats
path: root/testing/spl-git-grsec
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-11-16 14:57:13 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-11-16 15:44:03 +0000
commit762105a4e673a889711964433a0c35a8eb267dc5 (patch)
tree1aee56f2775ea10ad93a8c7190e9a70fe82796e9 /testing/spl-git-grsec
parent15e77dc1b7e476ce47bb1259a15b428b9e4c8f59 (diff)
downloadaports-762105a4e673a889711964433a0c35a8eb267dc5.tar.bz2
aports-762105a4e673a889711964433a0c35a8eb267dc5.tar.xz
testing/spl-git-grsec: upgrade to 20121116
Diffstat (limited to 'testing/spl-git-grsec')
-rw-r--r--testing/spl-git-grsec/APKBUILD41
1 files changed, 34 insertions, 7 deletions
diff --git a/testing/spl-git-grsec/APKBUILD b/testing/spl-git-grsec/APKBUILD
index 682cdd7fe..6b571357e 100644
--- a/testing/spl-git-grsec/APKBUILD
+++ b/testing/spl-git-grsec/APKBUILD
@@ -6,10 +6,10 @@ _name=$_realname-$_flavor
_kpkg=linux-$_flavor
_kver=3.6.6
-_kpkgrel=2
+_kpkgrel=0
-_mypkgrel=0
-_date=$(date +%Y%m%d)
+_mypkgrel=2
+_date=20121116
# source the kernel version
if [ -f ../../main/linux-$_flavor/APKBUILD ]; then
@@ -26,16 +26,43 @@ pkgver=$_kver
pkgrel=$(($_kpkgrel + $_mypkgrel))
pkgdesc="Solaris Porting Layer"
url="http://zfsonlinux.org"
-arch="x86_64"
+arch="x86 x86_64"
license="GPL"
depends=""
depends_dev="linux-grsec-dev"
makedepends="$depends_dev perl automake autoconf libtool"
install=""
subpackages="$pkgname-dev $_realname-utils:utils"
-source="saveas-https://github.com/zfsonlinux/spl/archive/master.tar.gz/spl-git-$_date.tar.gz"
-_builddir="$srcdir"/spl-master
+source="http://dev.alpinelinux.org/archive/$pkgname/$pkgname-$_date.tar.gz"
+_giturl="git://github.com/zfsonlinux/spl.git"
+_upload=dev.alpinelinux.org:/archive/$pkgname/
+
+_builddir="$srcdir"/$pkgname-$_date
+
+snapshot() {
+ _date=$(date +%Y%m%d)
+ local _pkg=$pkgname-$_date.tar.gz
+ mkdir -p "$srcdir"
+ cd "$srcdir"
+ rm -rf "$pkgname"
+ git clone --depth=1 --bare $_giturl || return 1
+ git --git-dir ${_giturl##*/} archive -o $_pkg \
+ --prefix=$pkgname-$_date/ HEAD \
+ || return 1
+ msg "New snapshot: $_pkg"
+ msg "Uploading to $_upload"
+ _newrel=$((_mypkgrel + 1))
+ scp $_pkg $_upload || return 1
+ cd ..
+ sed -i -e "s/^_mypkgrel=.*/_mypkgrel=$_newrel/" \
+ -e "s/^_date=.*/_date=$_date/" \
+ APKBUILD || return 1
+ _dir=${PWD%/APKBUILD}
+ _dir=${_dir%/*}
+ abuild checksum && abuild -r && git add APKBUILD \
+ && git commit -m"${_dir##*/}/$pkgname: snapshot $_date"
+}
prepare() {
local i
@@ -83,4 +110,4 @@ utils() {
"$pkgdir"/lib/ || return 1
}
-md5sums="9b736d4c458be637a145474532d1292a spl-git-20121108.tar.gz"
+md5sums="cbbc33f3025c645ecb7aa15bf83385af spl-git-grsec-20121116.tar.gz"