summaryrefslogtreecommitdiffstats
path: root/testing/stunnel
diff options
context:
space:
mode:
authordeant@hawaii.rr.com <deant@hawaii.rr.com>2012-07-08 17:07:28 -0400
committerNatanael Copa <ncopa@alpinelinux.org>2012-07-09 08:01:18 +0000
commit4ef696f942835f0c255ed9d337ec35707011f683 (patch)
treec349a546617a0b1065be88f4015323be9c31aecd /testing/stunnel
parentb47d0614be719e4697dcc6a0eac9826c9c662d44 (diff)
downloadaports-4ef696f942835f0c255ed9d337ec35707011f683.tar.bz2
aports-4ef696f942835f0c255ed9d337ec35707011f683.tar.xz
Initial APKBUILD for stunnel
SSL wrapper for TCP connections. See http://www.stunnel.org/ TODO: needs Alpine style initscript. reasonable defaults in sample config file (is there a preferred directory for chroot jails?) commit 8f4bfc56164419ecd3e7b91c77cf6d587b0cc16b Author: Dean Takemori <deant@hawaii.rr.com> Date: Sat Jul 7 09:01:16 2012 -1000 Add APKBUILD for stunnel to testing
Diffstat (limited to 'testing/stunnel')
-rw-r--r--testing/stunnel/APKBUILD48
1 files changed, 48 insertions, 0 deletions
diff --git a/testing/stunnel/APKBUILD b/testing/stunnel/APKBUILD
new file mode 100644
index 000000000..59f1478ef
--- /dev/null
+++ b/testing/stunnel/APKBUILD
@@ -0,0 +1,48 @@
+# Contributor: Dean Takemori <deant@hawaii.rr.com>
+# Maintainer:
+pkgname=stunnel
+pkgver=4.53
+pkgrel=0
+pkgdesc="SSL encryption wrapper between network client and server."
+url="http://www.stunnel.org/"
+arch="all"
+license="GPL2+ with OpenSSL exception"
+depends="openssl"
+depends_dev="openssl-dev"
+makedepends="$depends_dev"
+subpackages="$pkgname-doc"
+install=""
+source="ftp://ftp.stunnel.org/stunnel/$pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir/$pkgname-$pkgver"
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ install -m644 tools/stunnel.license \
+ "$pkgdir"/usr/share/doc/$pkgname/ || return 1
+
+ rm -f "$pkgdir"/usr/lib/stunnel/*.la
+}
+
+md5sums="ab3bfc915357d67da18c73f73610d593 stunnel-4.53.tar.gz"