summaryrefslogtreecommitdiffstats
path: root/testing/vnc2flv
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-09-20 13:20:29 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-09-20 13:21:17 +0000
commit50c87863123fe336ad00bf3643c46d9c7fe1af21 (patch)
tree8d59e7e8dee272080971c4b0e8f229c80bee7637 /testing/vnc2flv
parent587909cf329722913d32e16935b292880d69cfa4 (diff)
downloadaports-50c87863123fe336ad00bf3643c46d9c7fe1af21.tar.bz2
aports-50c87863123fe336ad00bf3643c46d9c7fe1af21.tar.xz
testing/vnc2flv: new aport
Screen recording tool that captures a VNC session and saves as FLV http://pypi.python.org/pypi/vnc2flv/
Diffstat (limited to 'testing/vnc2flv')
-rw-r--r--testing/vnc2flv/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/testing/vnc2flv/APKBUILD b/testing/vnc2flv/APKBUILD
new file mode 100644
index 000000000..9ff114150
--- /dev/null
+++ b/testing/vnc2flv/APKBUILD
@@ -0,0 +1,38 @@
+# Contributor:
+# Maintainer:
+pkgname=vnc2flv
+pkgver=20100207
+pkgrel=0
+pkgdesc="Screen recording tool that captures a VNC session and saves as FLV"
+url="http://pypi.python.org/pypi/vnc2flv/"
+arch="all"
+license="MIT/X"
+depends=""
+depends_dev=""
+makedepends="python-dev"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/v/vnc2flv/vnc2flv-$pkgver.tar.gz"
+
+_builddir="$srcdir"/vnc2flv-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="8492e46496e187b49fe5569b5639804e vnc2flv-20100207.tar.gz"