summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-10-17 13:28:42 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-10-17 13:28:47 +0000
commit10fcb682eb42a0b93bc3c6cd45c456b89bb910e4 (patch)
tree094560e48949f497ba9995c1d404617500b6a03b /testing
parent95be26274142dc58ead6b9e82cfa6cb0d2307dfc (diff)
downloadaports-10fcb682eb42a0b93bc3c6cd45c456b89bb910e4.tar.bz2
aports-10fcb682eb42a0b93bc3c6cd45c456b89bb910e4.tar.xz
testing/mp3splt-gtk: new aport
Gtk frontend for mp3splt http://mp3splt.sourceforge.net/ ref #769
Diffstat (limited to 'testing')
-rw-r--r--testing/mp3splt-gtk/APKBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/testing/mp3splt-gtk/APKBUILD b/testing/mp3splt-gtk/APKBUILD
new file mode 100644
index 000000000..f8b83a6de
--- /dev/null
+++ b/testing/mp3splt-gtk/APKBUILD
@@ -0,0 +1,42 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=mp3splt-gtk
+pkgver=0.7
+pkgrel=0
+pkgdesc="Gtk frontend for mp3splt"
+url="http://mp3splt.sourceforge.net/"
+arch="all"
+license="GPLv2"
+depends=""
+makedepends="gtk+-dev gst-plugins-base-dev gnome-doc-utils libmp3splt-dev
+ audacious-dev"
+install=""
+subpackages="$pkgname-doc $pkgname-lang"
+source="http://prdownloads.sourceforge.net/mp3splt/mp3splt-gtk-$pkgver.tar.gz"
+
+_builddir="$srcdir"/mp3splt-gtk-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --disable-gnome \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ rm -f "$pkgdir"/usr/lib/*.la
+}
+
+md5sums="a1cefffb7ea78ae7c07c8d3ba7a2630b mp3splt-gtk-0.7.tar.gz"