summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-10-16 19:37:42 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-10-16 19:37:42 +0000
commit159d61d15d7014a26202acb1011929b7feee118c (patch)
tree2728c9bb5e7be68b564c16d41445110f16b1d937 /testing
parente350a7e6745332ecbf3085729e94cde01717e79b (diff)
downloadaports-159d61d15d7014a26202acb1011929b7feee118c.tar.bz2
aports-159d61d15d7014a26202acb1011929b7feee118c.tar.xz
testing/twisted: new aport
Asynchronous networking framework written in Python. http://twistedmatrix.com/
Diffstat (limited to 'testing')
-rw-r--r--testing/twisted/APKBUILD18
1 files changed, 18 insertions, 0 deletions
diff --git a/testing/twisted/APKBUILD b/testing/twisted/APKBUILD
new file mode 100644
index 000000000..5afa3d760
--- /dev/null
+++ b/testing/twisted/APKBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=twisted
+pkgver=8.2.0
+pkgrel=0
+pkgdesc="Asynchronous networking framework written in Python."
+url="http://twistedmatrix.com/"
+license="MIT"
+depends="python pycrypto zope-interface"
+makedepends=""
+source="http://tmrc.mit.edu/mirror/$pkgname/Twisted/8.2/Twisted-$pkgver.tar.bz2"
+
+build ()
+{
+ cd "$srcdir"/Twisted-$pkgver
+ python setup.py install --prefix=/usr --root="$pkgdir"
+ install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}
+md5sums="c85f151999df3ecf04c49a781b4438d2 Twisted-8.2.0.tar.bz2"