summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2011-10-29 03:38:41 +0300
committerTimo Teräs <timo.teras@iki.fi>2011-10-29 03:39:34 +0300
commit4817196904e1f54616e525e06c0641cdbd201c98 (patch)
treed7627a101ab33a840e055a158bbcc891e5c2d58f /testing
parent836ed24811825271d4a4e865f358c9c3f59998ec (diff)
downloadaports-4817196904e1f54616e525e06c0641cdbd201c98.tar.bz2
aports-4817196904e1f54616e525e06c0641cdbd201c98.tar.xz
testing/php-phpmailer: new aport
PHP class for SMTP mailing http://code.google.com/a/apache-extras.org/p/phpmailer/
Diffstat (limited to 'testing')
-rw-r--r--testing/php-phpmailer/APKBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/testing/php-phpmailer/APKBUILD b/testing/php-phpmailer/APKBUILD
new file mode 100644
index 000000000..19a27a339
--- /dev/null
+++ b/testing/php-phpmailer/APKBUILD
@@ -0,0 +1,40 @@
+# Contributor: Timo Teräs <timo.teras@iki.fi>
+# Maintainer: Timo Teräs <timo.teras@iki.fi>
+pkgname=php-phpmailer
+_pkgname=PHPMailer
+pkgver=5.2.0
+pkgrel=0
+pkgdesc="PHP class for SMTP mailing"
+url="http://code.google.com/a/apache-extras.org/p/phpmailer/"
+arch="noarch"
+license="LGPL"
+depends="php>=5"
+depends_dev=
+makedepends="$depends_dev"
+install=""
+subpackages=""
+source="http://phpmailer.apache-extras.org.codespot.com/files/PHPMailer_$pkgver.tgz"
+
+_builddir="$srcdir/${_pkgname}_$pkgver"
+
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+}
+
+package() {
+ cd "$_builddir"
+ install -d -m755 "$pkgdir"/usr/share/pear
+ install -D -m644 "$_builddir"/class.*.php "$pkgdir"/usr/share/pear || return 1
+}
+
+md5sums="aed567b80e6a3b3175d4ce27f3a9a243 PHPMailer_5.2.0.tgz"