summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-03-21 14:29:26 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-03-21 14:29:26 +0000
commit5d9620463b748f38927b1080a39093cdfb929254 (patch)
treeda5090bda26ac3104a13ae22cc047aaf50deb078 /testing
parent36d09d5b6774ec30ffb5f996fd849cf42bcf7012 (diff)
downloadaports-5d9620463b748f38927b1080a39093cdfb929254.tar.bz2
aports-5d9620463b748f38927b1080a39093cdfb929254.tar.xz
testing/rrdcollect: simplify init.d
Diffstat (limited to 'testing')
-rw-r--r--testing/rrdcollect/APKBUILD14
-rw-r--r--testing/rrdcollect/rrdcollect.confd3
-rwxr-xr-xtesting/rrdcollect/rrdcollect.initd21
3 files changed, 6 insertions, 32 deletions
diff --git a/testing/rrdcollect/APKBUILD b/testing/rrdcollect/APKBUILD
index 688ccdd37..56e6499aa 100644
--- a/testing/rrdcollect/APKBUILD
+++ b/testing/rrdcollect/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Michael Mason <ms13sp@gmail.com>
pkgname=rrdcollect
pkgver=0.2.9
-pkgrel=1
+pkgrel=2
pkgdesc="Read system statistical data and feed it to RRDtool"
url="http://rrdcollect.sourceforge.net/"
arch="all"
@@ -12,9 +12,8 @@ makedepends="libpcap-dev"
install=
subpackages="$pkgname-doc"
source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz
-rrdcollect.conf.patch
-rrdcollect.confd
-rrdcollect.initd"
+ rrdcollect.conf.patch
+ rrdcollect.initd"
_builddir="$srcdir/$pkgname-$pkgver"
prepare() {
@@ -44,12 +43,11 @@ package() {
cd "$_builddir"
make DESTDIR="$pkgdir" install
- install -m755 -D "$srcdir"/rrdcollect.initd "$pkgdir"/etc/init.d/rrdcollect || return 1
- install -m644 -D "$srcdir"/rrdcollect.confd "$pkgdir"/etc/conf.d/rrdcollect || return 1
+ install -m755 -D "$srcdir"/rrdcollect.initd \
+ "$pkgdir"/etc/init.d/rrdcollect || return 1
install -m755 -d "$pkgdir"/var/lib/rrdtool || return 1
}
md5sums="1e94eb0f8d55ebf0f042c10baebc2d3d rrdcollect-0.2.9.tar.gz
e09d7a588e31c9ecfc44fd1747ad732b rrdcollect.conf.patch
-b3f64ec3e4578fb4de9614c20c6ea232 rrdcollect.confd
-edef974fb5a27279f9347d9eacda4a26 rrdcollect.initd"
+d5a892939ee11351f6bbbf9218694f8b rrdcollect.initd"
diff --git a/testing/rrdcollect/rrdcollect.confd b/testing/rrdcollect/rrdcollect.confd
deleted file mode 100644
index eb7e4fa82..000000000
--- a/testing/rrdcollect/rrdcollect.confd
+++ /dev/null
@@ -1,3 +0,0 @@
-# rrdcollect params suitable for running as a daemon
-
-RRD_OPTS=""
diff --git a/testing/rrdcollect/rrdcollect.initd b/testing/rrdcollect/rrdcollect.initd
index da566116e..883e574e1 100755
--- a/testing/rrdcollect/rrdcollect.initd
+++ b/testing/rrdcollect/rrdcollect.initd
@@ -3,25 +3,4 @@
description="rrdcollect daemon"
pidfile="/var/run/${RC_SVCNAME}.pid"
command="/usr/sbin/rrdcollect"
-runas="root"
-start_pre() {
- checkpath --directory --owner ${runas}:${runas} --mode 775 ${pidfile%/*}
-}
-
-start() {
- ebegin "Starting ${RC_SVCNAME}"
- start-stop-daemon --start \
- --user ${runas} \
- --pidfile ${pidfile} \
- --exec ${command} \
- -- ${RRD_OPTS}
- eend $?
-}
-
-stop() {
- ebegin "Stopping ${RC_SVCNAME}"
- start-stop-daemon --stop \
- --pidfile ${pidfile}
- eend $?
-}