summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-06-24 11:31:25 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-06-24 11:31:25 +0000
commit6186bbd0bd46751288a5e5568977ba1b39569d0e (patch)
treebbe7acfcf07e499e12e48967cf9c6c83cc4e7bdd /testing
parentf74c1bad0726852da9905fde909a50f3f9037ee0 (diff)
downloadaports-6186bbd0bd46751288a5e5568977ba1b39569d0e.tar.bz2
aports-6186bbd0bd46751288a5e5568977ba1b39569d0e.tar.xz
main/gc: moved from testing
Diffstat (limited to 'testing')
-rw-r--r--testing/gc/APKBUILD38
-rw-r--r--testing/gc/uclibc-getcontext.patch11
2 files changed, 0 insertions, 49 deletions
diff --git a/testing/gc/APKBUILD b/testing/gc/APKBUILD
deleted file mode 100644
index 065fba140..000000000
--- a/testing/gc/APKBUILD
+++ /dev/null
@@ -1,38 +0,0 @@
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
-pkgname=gc
-pkgver=7.1
-pkgrel=0
-pkgdesc="A garbage collector for C and C++"
-url="http://www.hpl.hp.com/personal/Hans_Boehm/gc/"
-license="GPL"
-depends=
-makedepends=
-subpackages="$pkgname-dev $pkgname-doc libgc++:libgccpp"
-source="http://www.hpl.hp.com/personal/Hans_Boehm/gc/gc_source/gc-$pkgver.tar.gz
- uclibc-getcontext.patch"
-
-prepare() {
- cd "$srcdir"/$pkgname-$pkgver
- patch -p1 -i "$srcdir"/uclibc-getcontext.patch || return 1
-}
-
-build() {
- cd "$srcdir"/$pkgname-$pkgver
- ./configure --prefix=/usr \
- --datadir=/usr/share/doc/gc \
- --enable-cplusplus || return 1
- make || return 1
-}
-
-package() {
- cd "$srcdir"/$pkgname-$pkgver
- make DESTDIR="$pkgdir" install || return 1
-}
-
-libgccpp() {
- install -d "$subpkgdir"/usr/lib
- mv "$pkgdir"/usr/lib/libgccpp.* "$subpkgdir"/usr/lib/
-}
-
-md5sums="2ff9924c7249ef7f736ecfe6f08f3f9b gc-7.1.tar.gz
-bce75c75bf0cdb295ac0bf7ba0f6e267 uclibc-getcontext.patch"
diff --git a/testing/gc/uclibc-getcontext.patch b/testing/gc/uclibc-getcontext.patch
deleted file mode 100644
index de48fc018..000000000
--- a/testing/gc/uclibc-getcontext.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./mach_dep.c.orig
-+++ ./mach_dep.c
-@@ -175,7 +175,7 @@
- # if defined(HAVE_PUSH_REGS)
- GC_push_regs();
- # elif defined(UNIX_LIKE) && !defined(DARWIN) && !defined(ARM32) && \
-- !defined(HURD)
-+ !defined(HURD) && !defined(__UCLIBC__)
- /* Older versions of Darwin seem to lack getcontext(). */
- /* ARM Linux often doesn't support a real getcontext(). */
- ucontext_t ctxt;