summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-01-04 09:16:19 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-01-04 09:16:19 +0000
commit6459d62f16074532c75436847ebd500ef5c4e901 (patch)
tree7d5e66d306a49ecf8ec19e87238ae446b13a5b1f /testing
parentb60e57c4f819be22d4691d4a0feff7f2e4931cdd (diff)
downloadaports-6459d62f16074532c75436847ebd500ef5c4e901.tar.bz2
aports-6459d62f16074532c75436847ebd500ef5c4e901.tar.xz
testing/wipe: new aport
tool for securely erasing files from magnetic media http://lambda-diode.com/software/wipe/
Diffstat (limited to 'testing')
-rw-r--r--testing/wipe/APKBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/testing/wipe/APKBUILD b/testing/wipe/APKBUILD
new file mode 100644
index 000000000..ac59ea345
--- /dev/null
+++ b/testing/wipe/APKBUILD
@@ -0,0 +1,40 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=wipe
+pkgver=0.22
+pkgrel=0
+pkgdesc="tool for securely erasing files from magnetic media"
+url="http://lambda-diode.com/software/wipe/"
+arch="all"
+license="GPL"
+depends=""
+depends_dev=""
+makedepends="$depends_dev"
+install=""
+subpackages=""
+source="http://lambda-diode.com/resources/wipe/wipe-$pkgver.tar.gz"
+
+_builddir="$srcdir"/wipe-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ make linux || return 1
+}
+
+package() {
+ cd "$_builddir"
+ install -d "$pkgdir"/usr/bin
+ make DESTDIR="$pkgdir" install || return 1
+ rm -f "$pkgdir"/usr/lib/*.la
+}
+
+md5sums="d5e0b2cdea9846f370f3b3f3b91fd593 wipe-0.22.tar.gz"