summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2011-01-21 23:24:34 -0600
committerWilliam Pitcock <nenolod@dereferenced.org>2011-01-21 23:24:34 -0600
commit754690b6c1ee4fe2868a640ed817c0bb289cd45b (patch)
tree4e8533ed2167e73227e7f0d1ec8c165f52fdccc8 /testing
parent54028b37df0f6790fa6639458467bb53bc19dbae (diff)
downloadaports-754690b6c1ee4fe2868a640ed817c0bb289cd45b.tar.bz2
aports-754690b6c1ee4fe2868a640ed817c0bb289cd45b.tar.xz
testing/xulrunner: git sucks
Diffstat (limited to 'testing')
-rw-r--r--testing/xulrunner/APKBUILD101
1 files changed, 101 insertions, 0 deletions
diff --git a/testing/xulrunner/APKBUILD b/testing/xulrunner/APKBUILD
new file mode 100644
index 000000000..bb05a9f7d
--- /dev/null
+++ b/testing/xulrunner/APKBUILD
@@ -0,0 +1,101 @@
+# Contributor: William Pitcock <nenolod@dereferenced.org>
+# Maintainer: William Pitcock <nenolod@dereferenced.org>
+pkgname=xulrunner
+pkgver=1.9.2.13
+pkgrel=0
+pkgdesc="runtime environment for xul-based applications"
+url="http://developer.mozilla.org/en/XULRunner"
+arch="all"
+license="GPL LGPL MPL"
+depends=
+depends_dev="nspr-dev
+ nss-dev
+ gtk+-dev
+ dbus-glib-dev
+ alsa-lib-dev
+ libvorbis-dev
+ libogg-dev
+ libtheora-dev
+ wireless-tools-dev
+ libnotify-dev
+ libevent-dev
+ libxt-dev
+ jpeg-dev
+ bzip2-dev
+ hunspell-dev
+ startup-notification-dev
+ sqlite-dev
+ libidl-dev"
+makedepends="$depends_dev
+
+ autoconf2.13
+
+ python
+ zip
+
+ autoconf
+ automake
+ libtool"
+install=""
+subpackages="$pkgname-dev"
+source="http://releases.mozilla.org/pub/mozilla.org/xulrunner/releases/${pkgver}/source/${pkgname}-${pkgver}.source.tar.bz2
+
+ mozconfig
+
+ enable-x86_64-tracemonkey.patch
+ fix-xulrunner-launcher.patch
+ mozilla-pkgconfig.patch
+
+ xulrunner-png14.patch
+ xulrunner-version.patch
+
+ mozjs-c99math.patch
+
+ ipc-chromium-uclibc.patch
+ ipc-chromium-execinfo.patch"
+
+_xulrunner_version="${pkgver%.*}"
+_builddir="${srcdir}/mozilla-${_xulrunner_version}"
+prepare() {
+ local i
+
+ cd "$_builddir"
+
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+
+ cp "${srcdir}/mozconfig" .mozconfig
+}
+
+build() {
+ cd "$_builddir"
+
+ # mozilla's buildsystem is on drugs, so we just kill our CFLAGS and hope
+ # for the best. --nenolod
+ unset CFLAGS
+ unset CXXFLAGS
+
+ make -j1 -f client.mk build MOZ_MAKE_FLAGS="$MAKEFLAGS" || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make -j1 DESTDIR="$pkgdir" install || return 1
+
+ install -d "${pkgdir}"/etc/ld.so.conf.d
+ echo "/usr/lib/xulrunner-1.9.2" > "${pkgdir}"/etc/ld.so.conf.d/xulrunner.conf
+}
+
+md5sums="211464d0b19b21ce0db63f7bd6549466 xulrunner-1.9.2.13.source.tar.bz2
+a2d246e51e0df2cb5ff050b7b14b2c52 mozconfig
+faecc31fd371db93311109117f6bcc40 enable-x86_64-tracemonkey.patch
+86d33a17286131d9ef4cdfb35ee56f1f fix-xulrunner-launcher.patch
+d839d1c4ef736e6d89ccf91b23b965a4 mozilla-pkgconfig.patch
+39e3c85c80f7897ac463e7fe7ad9a343 xulrunner-png14.patch
+371303c5bdc4fa0d955d14521b93b69d xulrunner-version.patch
+03b73ac11442a26a978c53a6c114ef2b mozjs-c99math.patch
+cc43eda512814f11079ce64001cd3652 ipc-chromium-uclibc.patch
+ac1c3725167eb26c89d62b1818810ee4 ipc-chromium-execinfo.patch"