summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2011-10-13 08:13:09 +0000
committerCarlo Landmeter <clandmeter@gmail.com>2011-10-13 08:13:09 +0000
commit785d6b68c3f5f048977fc361fe591085480fa5f4 (patch)
treea8bc930f989425094ee0081a515e0f8486022d1f /testing
parent877687e793a2758c4e6dbcbcc392ef7ab55e863a (diff)
downloadaports-785d6b68c3f5f048977fc361fe591085480fa5f4.tar.bz2
aports-785d6b68c3f5f048977fc361fe591085480fa5f4.tar.xz
main/mailx: move to main
Diffstat (limited to 'testing')
-rw-r--r--testing/mailx/APKBUILD44
-rw-r--r--testing/mailx/mailx-8.1.1.patch31
-rw-r--r--testing/mailx/mailx-gcc4.patch12
3 files changed, 0 insertions, 87 deletions
diff --git a/testing/mailx/APKBUILD b/testing/mailx/APKBUILD
deleted file mode 100644
index f656301b6..000000000
--- a/testing/mailx/APKBUILD
+++ /dev/null
@@ -1,44 +0,0 @@
-# Contributor: Carlo Landmeter <clandmeter@gmail.com>
-# Maintainer: Michael Mason <ms13sp@gmail.com>
-pkgname=mailx
-pkgver=8.1.1
-pkgrel=0
-pkgdesc="A commandline utility for sending email"
-url="http://www.opengroup.org/onlinepubs/007908799/xcu/mailx.html"
-arch="all"
-license="BSD"
-depends=
-depends_dev=
-makedepends="$depends_dev"
-install=""
-subpackages="$pkgname-doc"
-source="ftp://ftp.archlinux.org/other/mailx/$pkgname-$pkgver-fixed.tar.gz
- mailx-8.1.1.patch
- mailx-gcc4.patch"
-
-_builddir="$srcdir/$pkgname-$pkgver-fixed"
-
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p0 -i "$srcdir"/$i || return 1;;
- esac
- done
- sed -i 's#/man/#/share/man/#' Makefile
-}
-
-build() {
- cd "$_builddir"
- make || return 1
-}
-
-package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
-}
-
-md5sums="63cad526ac64b57bcba2c0daaa1f3048 mailx-8.1.1-fixed.tar.gz
-d66b9f419c5d215271ed434f5d780843 mailx-8.1.1.patch
-8716c7c7b3f5d348443230e2fe543bf6 mailx-gcc4.patch"
diff --git a/testing/mailx/mailx-8.1.1.patch b/testing/mailx/mailx-8.1.1.patch
deleted file mode 100644
index 536c28fc5..000000000
--- a/testing/mailx/mailx-8.1.1.patch
+++ /dev/null
@@ -1,31 +0,0 @@
---- Makefile Thu Mar 16 09:30:36 2000
-+++ Makefile Wed Feb 27 12:50:09 2002
-@@ -7,18 +7,20 @@
- BINOWN = root
- BINGRP = mail
-
-+DESTDIR =
-+
- all:
- gcc $(SRCS) -o $(PROG)
-
- install:
-- mkdir -p /usr/share/misc
-- mkdir -p /usr/share/man/man1
-- mkdir -p /etc
-- mkdir -p /usr/bin
-- install -o $(BINOWN) -g $(BINGRP) -m 2755 $(PROG) /usr/bin
-- install -o root -g root -m 644 mail.1 /usr/share/man/man1
-+ mkdir -p $(DESTDIR)/usr/share/misc
-+ mkdir -p $(DESTDIR)/usr/man/man1
-+ mkdir -p $(DESTDIR)/etc
-+ mkdir -p $(DESTDIR)/usr/bin
-+ install -o $(BINOWN) -g $(BINGRP) -m 2755 $(PROG) $(DESTDIR)/usr/bin
-+ install -o root -g root -m 644 mail.1 $(DESTDIR)/usr/man/man1
- cd misc; install -c -o ${BINOWN} -g ${BINGRP} \
-- -m 444 ${SFILES} /usr/share/misc
-+ -m 444 ${SFILES} $(DESTDIR)/usr/share/misc
- cd misc; install -c -o root -g root \
-- -m 644 ${EFILES} /etc
-+ -m 644 ${EFILES} $(DESTDIR)/etc
-
diff --git a/testing/mailx/mailx-gcc4.patch b/testing/mailx/mailx-gcc4.patch
deleted file mode 100644
index 54740a230..000000000
--- a/testing/mailx/mailx-gcc4.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-K. Piche: Unofficial patch for mailx.
-
---- dotlock.c.orig 2005-09-18 20:28:20.000000000 -0400
-+++ dotlock.c 2005-09-18 20:26:59.000000000 -0400
-@@ -47,6 +47,7 @@
- #include <errno.h>
- #include <signal.h>
-
-+#include "def.h"
- #include "extern.h"
-
- #ifndef O_SYNC