summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-05-31 13:49:59 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-05-31 13:49:59 +0000
commit984e8a9d1e20c3f1a694ae7b5700113bebb7ff22 (patch)
tree6ffd84c45ccc67f544977910b39b06a6f747de17 /testing
parent836edbffb7b7c0d414af65737d8fb44b3b7855ea (diff)
downloadaports-984e8a9d1e20c3f1a694ae7b5700113bebb7ff22.tar.bz2
aports-984e8a9d1e20c3f1a694ae7b5700113bebb7ff22.tar.xz
testing/perl-net-cidr: new aport
Manipulate IPv4/IPv6 netblocks in CIDR notation http://search.cpan.org/dist/Net-CIDR/
Diffstat (limited to 'testing')
-rw-r--r--testing/perl-net-cidr/APKBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/testing/perl-net-cidr/APKBUILD b/testing/perl-net-cidr/APKBUILD
new file mode 100644
index 000000000..1304a2746
--- /dev/null
+++ b/testing/perl-net-cidr/APKBUILD
@@ -0,0 +1,39 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=perl-net-cidr
+pkgver=0.14
+pkgrel=0
+pkgdesc="Manipulate IPv4/IPv6 netblocks in CIDR notation"
+url="http://search.cpan.org/dist/Net-CIDR/"
+arch="noarch"
+license="GPL+ or Artistic"
+depends="perl"
+makedepends="perl-dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/M/MR/MRSAM/testing/Net-CIDR-$pkgver.tar.gz"
+
+_builddir="$srcdir"/Net-CIDR-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
+ make && make test || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+md5sums="52081c62fe551a205127025c09698ec5 Net-CIDR-0.14.tar.gz"