summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-10-17 13:02:36 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-10-17 13:10:52 +0000
commit98c573092f8ff545b3f8963851e9b68dc768fc02 (patch)
tree6cca137c4e05aa71b1aee8996b4d67bb88696c2d /testing
parent1db231b1ab9b791d7fadb657830956be283508d1 (diff)
downloadaports-98c573092f8ff545b3f8963851e9b68dc768fc02.tar.bz2
aports-98c573092f8ff545b3f8963851e9b68dc768fc02.tar.xz
testing/mp3splt: new aport
A command-line, AlbumWrap and mp3wrap file exctractor http://mp3splt.sourceforge.net/ ref #769
Diffstat (limited to 'testing')
-rw-r--r--testing/mp3splt/APKBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/testing/mp3splt/APKBUILD b/testing/mp3splt/APKBUILD
new file mode 100644
index 000000000..b411ffee0
--- /dev/null
+++ b/testing/mp3splt/APKBUILD
@@ -0,0 +1,42 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=mp3splt
+pkgver=2.4
+pkgrel=0
+pkgdesc="A command-line, AlbumWrap and mp3wrap file exctractor"
+url="http://mp3splt.sourceforge.net/"
+arch="all"
+license="GPLv2"
+depends=""
+makedepends="libmp3splt-dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://prdownloads.sourceforge.net/mp3splt/mp3splt-$pkgver.tar.gz"
+
+_builddir="$srcdir"/mp3splt-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --with-mp3splt-includes=/usr/include/libmp3splt \
+ --enable-oggsplt_symlink \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ rm -f "$pkgdir"/usr/lib/*.la
+}
+
+md5sums="aa4dc3de6e789961c71d8b3daaac0623 mp3splt-2.4.tar.gz"