summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2012-11-28 15:42:40 +0100
committerCarlo Landmeter <clandmeter@gmail.com>2012-11-28 15:44:41 +0100
commit99c20fb4ce3c2bfd17861459c943db92a0e71c26 (patch)
tree8df746bea0250ce547119f6fd3baabe5e2ade20e /testing
parentbc9cf3fa2723cb6f9c331072cc36b9ce04ac3ce0 (diff)
downloadaports-99c20fb4ce3c2bfd17861459c943db92a0e71c26.tar.bz2
aports-99c20fb4ce3c2bfd17861459c943db92a0e71c26.tar.xz
testing/xbmc: new aport
Diffstat (limited to 'testing')
-rw-r--r--testing/xbmc/APKBUILD70
-rw-r--r--testing/xbmc/xbmc-uclibc.patch41
2 files changed, 111 insertions, 0 deletions
diff --git a/testing/xbmc/APKBUILD b/testing/xbmc/APKBUILD
new file mode 100644
index 000000000..3194062ea
--- /dev/null
+++ b/testing/xbmc/APKBUILD
@@ -0,0 +1,70 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer:
+pkgname=xbmc
+pkgver=12_beta1
+pkgrel=0
+pkgdesc="A software media player and entertainment hub for digital media"
+url="http://xbmc.org"
+arch="all"
+license="GPL"
+depends="python hicolor-icon-theme xdpyinfo libcrystalhd unrar"
+depends_dev="gettext-dev boost-dev mesa-dev glew-dev glu-dev mysql-dev libass-dev
+ libogg-dev libvorbis-dev libmodplug-dev curl-dev flac-dev libgcrypt-dev bzip2-dev
+ tiff-dev lzo-dev yajl-dev bluez-dev tinyxml-dev fribidi-dev sqlite-dev libpng-dev
+ libcdio-dev pcre-dev freetype-dev taglib-dev jasper-dev alsa-lib-dev dbus-dev
+ sdl-dev sdl_image-dev lame-dev libmicrohttpd-dev libbluray-dev avahi-dev
+ libxrandr-dev libxt-dev libxmu-dev samba-dev gawk libssh-dev libva-dev libnfs-dev
+ libusb-dev yasm-dev libmpeg2-dev libmad-dev libsamplerate-dev rtmpdump-dev
+ libjpeg-turbo-dev crystalhd-git-grsec-dev udev-dev libcap-dev udisks-dev faac-dev
+ libshairport-dev"
+makedepends="$depends_dev automake autoconf m4 libtool swig findutils openjdk6-jre-base
+ boost-thread zip gperf cmake coreutils"
+subpackages="$pkgname-dev $pkgname-doc"
+install=""
+options="ldpath-recursive"
+source="https://github.com/xbmc/xbmc/archive/Frodo_beta1.tar.gz
+ xbmc-uclibc.patch"
+
+_pvr_addons="git://github.com/opdenkamp/xbmc-pvr-addons.git"
+
+_builddir="$srcdir/xbmc-Frodo_beta1"
+
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+ #git clone $_pvr_addons pvr-addons || return 1
+}
+
+build() {
+ cd "$_builddir"
+ ./bootstrap || return 1
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ --disable-debug \
+ --enable-crystalhd \
+ --enable-vaapi \
+ --enable-ffmpeg-libvorbis \
+ --enable-rtmp \
+ --enable-joystick \
+ --enable-xrandr \
+ --enable-optical-drive \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ rm -f "$pkgdir"/usr/lib/*.la
+}
+
+md5sums="1d1d81073320cd8a270e1465b8f65a59 Frodo_beta1.tar.gz
+a089ae512a3e990ec85a78a4e79a29f5 xbmc-uclibc.patch"
diff --git a/testing/xbmc/xbmc-uclibc.patch b/testing/xbmc/xbmc-uclibc.patch
new file mode 100644
index 000000000..5ea62c200
--- /dev/null
+++ b/testing/xbmc/xbmc-uclibc.patch
@@ -0,0 +1,41 @@
+--- a/xbmc/cores/DllLoader/exports/util/EmuFileWrapper.h.orig
++++ b/xbmc/cores/DllLoader/exports/util/EmuFileWrapper.h
+@@ -27,8 +27,10 @@
+ #include "system.h"
+ #include "threads/CriticalSection.h"
+
+-#if defined(_LINUX) && !defined(TARGET_DARWIN) && !defined(__FreeBSD__) && !defined(__ANDROID__)
++#if defined(_LINUX) && !defined(TARGET_DARWIN) && !defined(__FreeBSD__) && !defined(__ANDROID__) && !defined(__UCLIBC__)
+ #define _file _fileno
++#elif defined(__UCLIBC__)
++#define _file __filedes
+ #endif
+
+ #define MAX_EMULATED_FILES 50
+--- a/xbmc/cores/DllLoader/exports/emu_msvcrt.h.orig
++++ b/xbmc/cores/DllLoader/exports/emu_msvcrt.h
+@@ -46,9 +46,9 @@
+
+ typedef void ( *PFV)(void);
+
+-#define __IS_STDIN_STREAM(stream) (stream == stdin || stream->_file == stdin->_file || stream->_file == 0)
+-#define __IS_STDOUT_STREAM(stream) (stream == stdout || stream->_file == stdout->_file || stream->_file == 1)
+-#define __IS_STDERR_STREAM(stream) (stream == stderr || stream->_file == stderr->_file || stream->_file == 2)
++#define __IS_STDIN_STREAM(stream) (stream == stdin || fileno(stream) == fileno(stdin) || fileno(stream) == 0)
++#define __IS_STDOUT_STREAM(stream) (stream == stdout || fileno(stream) == fileno(stdout) || fileno(stream) == 1)
++#define __IS_STDERR_STREAM(stream) (stream == stderr || fileno(stream) == fileno(stderr) || fileno(stream) == 2)
+ #define IS_STDIN_STREAM(stream) (stream != NULL && __IS_STDIN_STREAM(stream))
+ #define IS_STDOUT_STREAM(stream) (stream != NULL && __IS_STDOUT_STREAM(stream))
+ #define IS_STDERR_STREAM(stream) (stream != NULL && __IS_STDERR_STREAM(stream))
+--- a/xbmc/visualizations/XBMCProjectM/libprojectM/BeatDetect.cpp.orig
++++ b/xbmc/visualizations/XBMCProjectM/libprojectM/BeatDetect.cpp
+@@ -33,7 +33,7 @@
+
+ #include "Common.hpp"
+ #include "PCM.hpp"
+-#include <cmath>
++#include "math.h"
+ #include "BeatDetect.hpp"
+
+ #ifdef _WIN32
+