summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@gmail.com>2011-02-25 15:36:21 +0000
committerLeonardo Arena <rnalrd@gmail.com>2011-02-25 15:36:21 +0000
commita0880366d61d6621c0ae0a310eab1d923964d929 (patch)
treea7fc1e18de7e880d232550ca3ab71f7ac4771c0c /testing
parent5cfbd9cb03b028e2a9263753d8350173fa4cb08d (diff)
downloadaports-a0880366d61d6621c0ae0a310eab1d923964d929.tar.bz2
aports-a0880366d61d6621c0ae0a310eab1d923964d929.tar.xz
testing/coova-chilli: move to main
Diffstat (limited to 'testing')
-rw-r--r--testing/coova-chilli/APKBUILD51
-rwxr-xr-xtesting/coova-chilli/chilli.initd42
-rw-r--r--testing/coova-chilli/coova-chilli-ssl.patch21
3 files changed, 0 insertions, 114 deletions
diff --git a/testing/coova-chilli/APKBUILD b/testing/coova-chilli/APKBUILD
deleted file mode 100644
index 37ec1091f..000000000
--- a/testing/coova-chilli/APKBUILD
+++ /dev/null
@@ -1,51 +0,0 @@
-# Contributor: grharry
-# Maintainer: Leonardo Arena <rnalrd@gmail.com>
-pkgname=coova-chilli
-pkgver=1.2.6
-pkgrel=1
-pkgdesc="CoovaChilli is an open source access controller for wireless LAN"
-url="http://www.coova.org/"
-arch="all"
-license="GPL"
-depends=
-makedepends="perl openssl-dev autoconf automake libtool"
-install=
-subpackages="$pkgname-doc $pkgname-dev"
-source="http://ap.coova.org/chilli/coova-chilli-$pkgver.tar.gz
- coova-chilli-ssl.patch"
-
-_builddir="$srcdir/$pkgname-$pkgver"
-
-prepare() {
- cd $_builddir
-# patch -p1 -i ../coova-chilli-ssl.patch || return 1
- sed -i 's/-Werror//g' src/Makefile.am || return 1
- sed -i 's/-Werror//g' src/Makefile.in || return 1
- sed -i 's%(localstatedir)/run%(localstatedir)%' src/Makefile.am || return 1
- sed -i 's%(localstatedir)/run%(localstatedir)%' src/Makefile.in || return 1
- aclocal && autoconf && automake && libtoolize || return 1
-}
-
-build() {
- cd $_builddir
- ./configure --prefix=/usr \
- --sysconfdir=/etc \
- --mandir=/usr/share/man \
- --infodir=/usr/share/info \
- --localstatedir=/var/run/chilli \
- --libdir=/usr/lib \
- --sysconfdir=/etc \
- --with-openssl \
- --enable-dhcpopt
- make -j1 || return 1
-}
-
-package() {
- cd $_builddir
- make DESTDIR="$pkgdir" install
- install -D -m755 ../../chilli.initd $pkgdir/etc/init.d/chilli
- mkdir -p $pkgdir/var/run/chilli
-}
-
-md5sums="3153c200dad514976760dc5176ee8897 coova-chilli-1.2.6.tar.gz
-4135e6e19bafdad777b8ca7388ff4101 coova-chilli-ssl.patch"
diff --git a/testing/coova-chilli/chilli.initd b/testing/coova-chilli/chilli.initd
deleted file mode 100755
index fe6ec72d5..000000000
--- a/testing/coova-chilli/chilli.initd
+++ /dev/null
@@ -1,42 +0,0 @@
-#!/sbin/runscript
-
-depend() {
- use net
- after firewall
- provide chilli
-}
-
-
-checkconfig() {
- if [ -f /etc/chilli.conf ]; then
- return 0;
- else
- eerror "Error starting CoovaChilli. Please create /etc/chilli.conf before."
- return 1;
- fi
-
-}
-
-start() {
- checkconfig || return 1
- ebegin "Starting CoovaChilli Captive Portal"
-
- echo 1 > /proc/sys/net/ipv4/ip_forward
- lsmod | grep tun >& /dev/null
-
- if [ $? -ne 0 ]; then
- modprobe tun >& /dev/null
- fi
-
- start-stop-daemon --start --pidfile /var/run/chilli/chilli.pid --quiet \
- --exec /usr/sbin/chilli -- --pidfile=/var/run/chilli/chilli.pid
- eend $?
-}
-
-stop() {
- ebegin "Stopping CoovaChilli Captive Portal"
- start-stop-daemon --stop --pidfile /var/run/chilli.pid --quiet
- eend $?
-}
-
-
diff --git a/testing/coova-chilli/coova-chilli-ssl.patch b/testing/coova-chilli/coova-chilli-ssl.patch
deleted file mode 100644
index 1567c96cb..000000000
--- a/testing/coova-chilli/coova-chilli-ssl.patch
+++ /dev/null
@@ -1,21 +0,0 @@
---- a/src/Makefile.am
-+++ b/src/Makefile.am
-@@ -13,7 +13,8 @@
- chilli.h options.h util.c garden.c garden.h ssl.h ssl.c \
- dns.c dns.h session.c session.h limits.h pkt.h pkt.c \
- chksum.c net.h net.c ms_chap.c options.c statusfile.c \
--conn.h conn.c
-+conn.h conn.c
-+libchilli_la_LIBADD = $(LIBOPENSSL)
-
- AM_CFLAGS = -D_GNU_SOURCE -Wall -fno-builtin -fno-strict-aliasing \
- -O2 -fomit-frame-pointer -funroll-loops -pipe \
-@@ -33,7 +34,7 @@
- #test_radius_SOURCES = test-radius.c
- #test_dhcp_SOURCES = test-dhcp.c
-
--LDADD = libchilli.la $(top_builddir)/bstring/libbstring.la ${LIBRT}
-+LDADD = libchilli.la $(top_builddir)/bstring/libbstring.la $(LIBOPENSSL)
-
- if WITH_OPENSSL
- LDADD += ${LIBSSL}