summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2009-03-26 16:10:38 +0000
committerCarlo Landmeter <clandmeter@gmail.com>2009-03-26 16:10:38 +0000
commita0e1257e5a4f840c5b706aac57fef63c8030b8de (patch)
tree81af73fc689661117742cae1a8697f7c16ec84a1 /testing
parent44ddbd6cdc9355973c52a8be09afdaf103011442 (diff)
downloadaports-a0e1257e5a4f840c5b706aac57fef63c8030b8de.tar.bz2
aports-a0e1257e5a4f840c5b706aac57fef63c8030b8de.tar.xz
testing/php-apc: new aport
Diffstat (limited to 'testing')
-rw-r--r--testing/php-apc/APKBUILD32
-rw-r--r--testing/php-apc/apc.ini11
2 files changed, 43 insertions, 0 deletions
diff --git a/testing/php-apc/APKBUILD b/testing/php-apc/APKBUILD
new file mode 100644
index 000000000..0f4b4bbf9
--- /dev/null
+++ b/testing/php-apc/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer: Carlo Landmeter <clandmeter@gmail.com>
+pkgname=php-apc
+pkgver=3.1.2
+pkgrel=0
+pkgdesc="Alternative PHP Cache"
+url="http://pecl.php.net/package/APC"
+license="PHP"
+depends="php"
+makedepends="php-dev autoconf pcre-dev"
+install=
+subpackages=""
+source="http://pecl.php.net/get/APC-3.1.2.tgz
+apc.ini"
+
+build() {
+ cd "$srcdir/APC-${pkgver}"
+
+ phpize || return 1
+ ./configure --prefix=/usr \
+ --enable-apc \
+ --enable-apc-mmap \
+ --with-apxs \
+ --with-php-config=/usr/bin/php-config
+ make || return 1
+ make INSTALL_ROOT=$pkgdir install || return 1
+ install -D -m644 "$srcdir"/apc.ini "$pkgdir"/etc/php/conf.d/apc.ini
+
+}
+
+md5sums="0a18cf164b3e044e27edd4c1d8c3145c APC-3.1.2.tgz
+45224019b659aa60ac540eef08ae8413 apc.ini"
diff --git a/testing/php-apc/apc.ini b/testing/php-apc/apc.ini
new file mode 100644
index 000000000..4dabec217
--- /dev/null
+++ b/testing/php-apc/apc.ini
@@ -0,0 +1,11 @@
+;PHP suggest APC settings
+extension=apc.so
+apc.enabled=1
+apc.shm_segments=1
+apc.shm_size=128
+apc.ttl=7200
+apc.user_ttl=7200
+apc.num_files_hint=1024
+apc.mmap_file_mask=/tmp/apc.XXXXXX
+apc.enable_cli=1
+