summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorKiyoshi Aman <aphrael@alpinelinux.org>2011-04-27 02:31:09 -0400
committerKiyoshi Aman <aphrael@alpinelinux.org>2011-04-27 02:31:54 -0400
commitd6517e9f72c7a8cd72a72f1647065c37f49cc5b1 (patch)
tree19cbae1c030feddc4bd4cc6cca2e5dadc4e9f01d /testing
parentf8f918734e5dcba760aaf1a59d57849b61cbddf3 (diff)
downloadaports-d6517e9f72c7a8cd72a72f1647065c37f49cc5b1.tar.bz2
aports-d6517e9f72c7a8cd72a72f1647065c37f49cc5b1.tar.xz
testing/xf86-video-nouveau: new aport
Diffstat (limited to 'testing')
-rw-r--r--testing/xf86-video-nouveau/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/testing/xf86-video-nouveau/APKBUILD b/testing/xf86-video-nouveau/APKBUILD
new file mode 100644
index 000000000..c006aa657
--- /dev/null
+++ b/testing/xf86-video-nouveau/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor:
+# Maintainer:
+pkgname=xf86-video-nouveau
+pkgver=0.0.16
+pkgrel=0
+pkgdesc="Open-source X.org drivers for nVidia video cards"
+url="http://nouveau.freedesktop.org/"
+arch="all"
+license="MIT"
+depends="mesa-dri-nouveau"
+depends_dev=
+makedepends="pkgconfig randrproto renderproto videoproto xextproto libdrm-dev xorg-server-dev util-macros libtool autoconf automake xf86driproto"
+install=""
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://ftp.de.debian.org/debian/pool/main/x/xserver-xorg-video-nouveau/xserver-xorg-video-nouveau_$pkgver+git20101210+8bb8231.orig.tar.gz"
+
+_builddir="$srcdir/$pkgname"
+
+build() {
+ cd "$_builddir"
+ ./autogen.sh --prefix=/usr || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="65067b46401f385ba833130d634fe319 xserver-xorg-video-nouveau_0.0.16+git20101210+8bb8231.orig.tar.gz"