summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-10-27 12:56:26 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-10-27 13:00:27 +0000
commite900043966e2ded32ae69b6f06854156dc50b32c (patch)
tree47d6fc32d115452fb4e4c31bde818984260ebed5 /testing
parent228954dbe482910f3fc92faece1627a636b73299 (diff)
downloadaports-e900043966e2ded32ae69b6f06854156dc50b32c.tar.bz2
aports-e900043966e2ded32ae69b6f06854156dc50b32c.tar.xz
testing/liboping: new aport
A Ping Lib http://verplant.org/liboping/
Diffstat (limited to 'testing')
-rw-r--r--testing/liboping/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/testing/liboping/APKBUILD b/testing/liboping/APKBUILD
new file mode 100644
index 000000000..438b967e7
--- /dev/null
+++ b/testing/liboping/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: Harry
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=liboping
+pkgver=1.6.1
+pkgrel=0
+pkgdesc="A Ping Lib"
+url="http://verplant.org/liboping/"
+arch="all"
+license=GPL
+depends=
+# make install needs setcap provided by libcap
+makedepends="ncurses-dev libcap"
+source="http://verplant.org/liboping/files/$pkgname-$pkgver.tar.bz2"
+subpackages="$pkgname-dev $pkgname-doc"
+
+_builddir="$srcdir/$pkgname-$pkgver"
+prepare() {
+ cd "$_builddir"
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --libdir=/usr/lib \
+ --without-perl-bindings \
+ --disable-static \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make install DESTDIR="$pkgdir" || return 1
+ rm "$pkgdir"/usr/lib/*.la || return 1
+}
+
+md5sums="748554a18e1771913f4f402ee9f957c9 liboping-1.6.1.tar.bz2"