summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2011-10-13 08:24:19 +0000
committerCarlo Landmeter <clandmeter@gmail.com>2011-10-13 08:24:19 +0000
commitfc3460fd2a47df414548426907a856874a076371 (patch)
tree59bf5d687f38a3d2940e945fadd88ef095951e1f /testing
parentbf82e002330b7b1523e8e6bbb99ba09ec44d201b (diff)
downloadaports-fc3460fd2a47df414548426907a856874a076371.tar.bz2
aports-fc3460fd2a47df414548426907a856874a076371.tar.xz
main/procmail: move to main
Diffstat (limited to 'testing')
-rw-r--r--testing/procmail/APKBUILD46
-rw-r--r--testing/procmail/procmail-3.22-getline.patch56
2 files changed, 0 insertions, 102 deletions
diff --git a/testing/procmail/APKBUILD b/testing/procmail/APKBUILD
deleted file mode 100644
index ddf980fa3..000000000
--- a/testing/procmail/APKBUILD
+++ /dev/null
@@ -1,46 +0,0 @@
-# Contributor: Carlo Landmeter <clandmeter@gmail.com>
-# Maintainer: Carlo Landmeter <clandmeter@gmail.com>
-pkgname=procmail
-pkgver=3.22
-pkgrel=0
-pkgdesc="Highly configurable auto mail processing"
-url="http://www.procmail.org"
-arch="all"
-license="GPL"
-depends=""
-depends_dev=""
-makedepends="$depends_dev"
-install=""
-subpackages="$pkgname-doc"
-source="ftp://ftp.informatik.rwth-aachen.de/pub/packages/procmail/procmail-$pkgver.tar.gz
-procmail-3.22-getline.patch"
-
-_builddir="$srcdir"/procmail-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
-
-build() {
- cd "$_builddir"
- yes n | make CFLAGS0="${CFLAGS} ${LDFLAGS}" \
- LOCKINGTEST="/tmp ." || return 1
-}
-
-package() {
- cd "$_builddir"
- make BASENAME=${pkgdir}/usr MANDIR=${pkgdir}/usr/share/man \
- install || return 1
- rm -f "$pkgdir"/usr/lib/*.la
- install -D -m644 Artistic ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
- install -d -m755 ${pkgdir}/usr/share/doc/${pkgname}/examples
- install -m644 examples/* ${pkgdir}/usr/share/doc/${pkgname}/examples/
-}
-
-md5sums="1678ea99b973eb77eda4ecf6acae53f1 procmail-3.22.tar.gz
-cf8e5d4854050ab0c836e07406a3dfa9 procmail-3.22-getline.patch"
diff --git a/testing/procmail/procmail-3.22-getline.patch b/testing/procmail/procmail-3.22-getline.patch
deleted file mode 100644
index fb9a4ec6e..000000000
--- a/testing/procmail/procmail-3.22-getline.patch
+++ /dev/null
@@ -1,56 +0,0 @@
-diff -up procmail-3.22/src/fields.c.getline procmail-3.22/src/fields.c
---- procmail-3.22/src/fields.c.getline 2001-09-11 06:57:08.000000000 +0200
-+++ procmail-3.22/src/fields.c 2009-06-30 16:10:36.000000000 +0200
-@@ -110,16 +110,16 @@ void dispfield(p)register const struct f
- /* try and append one valid field to rdheader from stdin */
- int readhead P((void))
- { int idlen;
-- getline();
-+ get_line();
- if((idlen=breakfield(buf,buffilled))<=0) /* not the start of a valid field */
- return 0;
- if(idlen==STRLEN(FROM)&&eqFrom_(buf)) /* it's a From_ line */
- { if(rdheader)
- return 0; /* the From_ line was a fake! */
-- for(;buflast=='>';getline()); /* gather continued >From_ lines */
-+ for(;buflast=='>';get_line()); /* gather continued >From_ lines */
- }
- else
-- for(;;getline()) /* get the rest of the continued field */
-+ for(;;get_line()) /* get the rest of the continued field */
- { switch(buflast) /* will this line be continued? */
- { case ' ':case '\t': /* yep, it sure is */
- continue;
-diff -up procmail-3.22/src/formail.c.getline procmail-3.22/src/formail.c
---- procmail-3.22/src/formail.c.getline 2009-06-30 16:00:40.000000000 +0200
-+++ procmail-3.22/src/formail.c 2009-06-30 16:10:49.000000000 +0200
-@@ -819,7 +819,7 @@ splitit: { if(!lnl) /* did the p
- { if(split) /* gobble up the next start separator */
- { buffilled=0;
- #ifdef sMAILBOX_SEPARATOR
-- getline();buffilled=0; /* but only if it's defined */
-+ get_line();buffilled=0; /* but only if it's defined */
- #endif
- if(buflast!=EOF) /* if any */
- goto splitit;
-diff -up procmail-3.22/src/formisc.c.getline procmail-3.22/src/formisc.c
---- procmail-3.22/src/formisc.c.getline 2001-06-29 04:20:45.000000000 +0200
-+++ procmail-3.22/src/formisc.c 2009-06-30 16:12:20.000000000 +0200
-@@ -115,7 +115,7 @@ void loadchar(c)const int c; /* a
- buf[buffilled++]=c;
- }
-
--int getline P((void)) /* read a newline-terminated line */
-+int get_line P((void)) /* read a newline-terminated line */
- { if(buflast==EOF) /* at the end of our Latin already? */
- { loadchar('\n'); /* fake empty line */
- return EOF; /* spread the word */
-diff -up procmail-3.22/src/formisc.h.getline procmail-3.22/src/formisc.h
---- procmail-3.22/src/formisc.h.getline 1999-04-19 08:42:15.000000000 +0200
-+++ procmail-3.22/src/formisc.h 2009-06-30 16:10:02.000000000 +0200
-@@ -17,4 +17,4 @@ void
- char*
- skipwords P((char*start));
- int
-- getline P((void));
-+ get_line P((void));