summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/asterisk/APKBUILD17
1 files changed, 13 insertions, 4 deletions
diff --git a/main/asterisk/APKBUILD b/main/asterisk/APKBUILD
index 77b699adf..a8c5d110a 100644
--- a/main/asterisk/APKBUILD
+++ b/main/asterisk/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Timo Teras <timo.teras@iki.fi>
# Maintainer: Timo Teras <timo.teras@iki.fi>
pkgname=asterisk
-pkgver=1.6.2.8
+pkgver=1.6.2.9
pkgrel=0
pkgdesc="Asterisk: A Module Open Source PBX System"
url="http://www.asterisk.org/"
@@ -9,10 +9,11 @@ license="GPL"
depends=
makedepends="autoconf automake libtool ncurses-dev popt-dev newt-dev zlib-dev
postgresql-dev unixodbc-dev dahdi-tools-dev libpri-dev tar
- freetds-dev openssl-dev lua-dev alsa-lib-dev spandsp-dev tiff-dev"
+ freetds-dev openssl-dev lua-dev alsa-lib-dev spandsp-dev tiff-dev
+ libresample sqlite-dev"
install="$pkgname.pre-install $pkgname.pre-upgrade $pkgname.post-install"
subpackages="$pkgname-dev $pkgname-doc $pkgname-pgsql $pkgname-odbc
- $pkgname-tds $pkgname-fax $pkgname-sample-config:sample"
+ $pkgname-tds $pkgname-fax $pkgname-sample-config:sample $pkgname-sqlite"
source="http://downloads.digium.com/pub/asterisk/releases/$pkgname-$pkgver.tar.gz
100-uclibc-daemon.patch
101-caps-uclibc.patch
@@ -48,6 +49,8 @@ build() {
--without-iconv --with-popt --with-z --with-newt \
--with-odbc --with-postgres --with-tds \
--with-dahdi --with-pri --with-tonezone \
+ --with-resample \
+ --with-sqlite3 \
--with-asound \
--without-x11 \
--with-spandsp \
@@ -86,6 +89,12 @@ pgsql() {
_find_and_move '*_pgsql*'
}
+sqlite() {
+ depends=
+ install=
+ _find_and_move '*_sqlite*'
+}
+
odbc() {
depends=
install=
@@ -110,7 +119,7 @@ sample() {
make samples DESTDIR="$subpkgdir"
}
-md5sums="2ee5bbb91771c7c9b131da473971bc2f asterisk-1.6.2.8.tar.gz
+md5sums="1f947d951c419b8039d53a6e6168fd69 asterisk-1.6.2.9.tar.gz
b00c9d98ce2ad445501248a197c6e436 100-uclibc-daemon.patch
6e1129e30c4fd2c25c86c81685a485a9 101-caps-uclibc.patch
79e9634b5054bceb3b8dc246654bb243 400-bug-227.patch