summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--core/fakeroot/APKBUILD18
1 files changed, 18 insertions, 0 deletions
diff --git a/core/fakeroot/APKBUILD b/core/fakeroot/APKBUILD
new file mode 100644
index 000000000..3922a80e7
--- /dev/null
+++ b/core/fakeroot/APKBUILD
@@ -0,0 +1,18 @@
+pkgname=fakeroot
+pkgver=1.10.1
+pkgrel=0
+pkgdesc="Gives a fake root environment, useful for building packages as a non-privileged user"
+license='GPL'
+url="http://packages.debian.org/fakeroot"
+install=fakeroot.install
+depends='uclibc'
+makedepends='binutils gcc make linux-headers uclibc-dev'
+source=http://ftp.debian.org/debian/pool/main/f/$pkgname/${pkgname}_${pkgver}.tar.gz
+
+build() {
+ cd $startdir/src/$pkgname-$pkgver
+ ./configure --prefix=/usr #--libdir=/usr/lib/libfakeroot
+ make || return 1
+ make DESTDIR=$startdir/pkg install
+}
+md5sums="052a1b5474b3681bc5f3167d2b3711a8 fakeroot_1.10.1.tar.gz"