summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/pureftpd/APKBUILD13
-rw-r--r--testing/pureftpd/pure-ftpd.initd4
2 files changed, 10 insertions, 7 deletions
diff --git a/testing/pureftpd/APKBUILD b/testing/pureftpd/APKBUILD
index 6dcce82e6..8a5110df7 100644
--- a/testing/pureftpd/APKBUILD
+++ b/testing/pureftpd/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Douglas Haber <me@douglashaber.com>
-# Maintainer:
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=pure-ftpd
pkgver=1.0.30
-pkgrel=0
+pkgrel=1
pkgdesc="Pure FTPD FTP daemon"
url="http://pureftpd.org"
arch="all"
@@ -28,7 +28,12 @@ prepare() {
build() {
cd "$_builddir"
- ./configure --without-humor --without-unicode --with-minimal --with-throttling || return 1
+ ./configure --prefix=/usr \
+ --without-humor \
+ --without-unicode \
+ --with-minimal \
+ --with-throttling \
+ || return 1
make || return 1
}
@@ -41,4 +46,4 @@ package() {
}
md5sums="29e2a68e756d09f4aff8f4f76435b020 pure-ftpd-1.0.30.tar.gz
-3608b0f85e7731aec64c251f9b73907a pure-ftpd.initd"
+a37d043f3df4595b2d39aa1083705948 pure-ftpd.initd"
diff --git a/testing/pureftpd/pure-ftpd.initd b/testing/pureftpd/pure-ftpd.initd
index 0096fc0e8..ea55116e6 100644
--- a/testing/pureftpd/pure-ftpd.initd
+++ b/testing/pureftpd/pure-ftpd.initd
@@ -1,9 +1,7 @@
#!/sbin/runscript
-# Sample init.d file for alpine linux.
-
name=pure-ftpd
-daemon=/usr/local/sbin/$name
+daemon=/usr/sbin/$name
depend() {
need net