summaryrefslogtreecommitdiffstats
path: root/main/asterisk-audio-konf/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/asterisk-audio-konf/APKBUILD')
-rw-r--r--main/asterisk-audio-konf/APKBUILD67
1 files changed, 67 insertions, 0 deletions
diff --git a/main/asterisk-audio-konf/APKBUILD b/main/asterisk-audio-konf/APKBUILD
new file mode 100644
index 000000000..cd87e2780
--- /dev/null
+++ b/main/asterisk-audio-konf/APKBUILD
@@ -0,0 +1,67 @@
+# Contributor:
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=asterisk-audio-konf
+_basever=0
+_gitver=100607
+pkgver=${_basever}_git${_gitver}
+pkgrel=0
+pkgdesc="A fork of AppKonference focused entirely on audio conferencing"
+url="http://github.com/jthomerson/AsteriskAudioKonf/"
+license="GPL"
+depends=
+makedepends="asterisk-dev"
+install=
+subpackages=
+_snapfile="$pkgname-$pkgver.tar.bz2"
+source="http://build.alpinelinux.org:8010/distfiles/$_snapfile
+ 0001-add-n-flag-to-prevent-dynamic-create-of-conference.patch
+ "
+
+_gitver=100607
+_giturl="git://github.com/jthomerson/AsteriskAudioKonf.git"
+
+
+_builddir="$srcdir"/$pkgname/konference
+
+
+snapshot() {
+ _gitver=$(date +%y%m%d)
+ pkgver=${_basever}_git$_gitver
+ _snapfile="$pkgname-$pkgver.tar.bz2"
+
+ if [ -d "$SRCDEST"/$pkgname ]; then
+ cd "$SRCDEST"/$pkgname
+ git pull --rebase || return 1
+ else
+ cd "$SRCDEST"
+ git clone $_giturl $pkgname
+ fi
+ cd "$SRCDEST"
+ tar -jcf $_snapfile $pkgname
+
+ pkgrel=0
+ sed -i -e "s/^_gitver=.*/_gitver=${_gitver}/" \
+ -e "s/^pkgrel=.*/pkgrel=$pkgrel/" \
+ "$startdir"/APKBUILD
+ checksum
+}
+
+prepare() {
+ cd "$_builddir"/..
+ for i in "$srcdir"/*.patch; do
+ patch -p1 -i "$i" || return 1
+ done
+}
+
+build() {
+ cd "$_builddir"
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make INSTALL_PREFIX="$pkgdir" install
+}
+
+md5sums="8a716a2d1daa622f86a485804e403571 asterisk-audio-konf-0_git100607.tar.bz2
+937afbb9fa2ce57615f09919e15ab2d3 0001-add-n-flag-to-prevent-dynamic-create-of-conference.patch"