summaryrefslogtreecommitdiffstats
path: root/main/groff/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/groff/APKBUILD')
-rw-r--r--main/groff/APKBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/main/groff/APKBUILD b/main/groff/APKBUILD
new file mode 100644
index 000000000..01f270871
--- /dev/null
+++ b/main/groff/APKBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=groff
+pkgver=1.21
+pkgrel=0
+pkgdesc="GNU troff text-formatting system"
+url="http://www.gnu.org/software/groff/groff.html"
+arch="all"
+license="GPL"
+depends=
+makedepends="perl texinfo"
+subpackages="$pkgname-doc"
+source="ftp://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.gz"
+
+build () {
+ cd "$srcdir/$pkgname-$pkgver"
+ ./configure --prefix=/usr --without-x
+ make || return 1
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+}
+md5sums="8b8cd29385b97616a0f0d96d0951c5bf groff-1.21.tar.gz"