summaryrefslogtreecommitdiffstats
path: root/main/heimdal/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/heimdal/APKBUILD')
-rw-r--r--main/heimdal/APKBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/main/heimdal/APKBUILD b/main/heimdal/APKBUILD
index d7e47b9eb..15221bb69 100644
--- a/main/heimdal/APKBUILD
+++ b/main/heimdal/APKBUILD
@@ -2,15 +2,15 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
pkgname=heimdal
pkgver=1.4
-pkgrel=5
+pkgrel=6
pkgdesc="An implementation of Kerberos 5"
arch="all"
url="http://www.h5l.org/"
license="BSD"
depends=
depends_dev="openssl-dev e2fsprogs-dev"
-makedepends="autoconf automake e2fsprogs-dev>=1.41.9-r2 gawk libtool openssl-dev
- pkgconfig readline-dev sqlite-dev"
+makedepends="autoconf automake db-dev e2fsprogs-dev>=1.41.9-r2 gawk libtool
+ openssl-dev pkgconfig readline-dev sqlite-dev"
install=
subpackages="$pkgname-doc $pkgname-dev $pkgname-ftp $pkgname-telnet \
$pkgname-su $pkgname-rsh $pkgname-rcp $pkgname-pagsh $pkgname-kf"
@@ -49,11 +49,12 @@ prepare() {
build() {
cd "$_builddir"
export LDFLAGS="${LDFLAGS} -Wl,--as-needed"
+ export LIBS="-ldb"
./configure --prefix=/usr \
--enable-shared=yes \
--without-x \
- --disable-berkeley-db \
+ --with-berkeley-db \
--with-readline-lib=/usr/lib \
--with-readline-include=/usr/include/readline \
--with-openssl=/usr