summaryrefslogtreecommitdiffstats
path: root/main/libc0.9.32/0021-libcrypt-add-support-for-SHA256-CRYPT-password-hashi.patch
diff options
context:
space:
mode:
Diffstat (limited to 'main/libc0.9.32/0021-libcrypt-add-support-for-SHA256-CRYPT-password-hashi.patch')
-rw-r--r--main/libc0.9.32/0021-libcrypt-add-support-for-SHA256-CRYPT-password-hashi.patch789
1 files changed, 789 insertions, 0 deletions
diff --git a/main/libc0.9.32/0021-libcrypt-add-support-for-SHA256-CRYPT-password-hashi.patch b/main/libc0.9.32/0021-libcrypt-add-support-for-SHA256-CRYPT-password-hashi.patch
new file mode 100644
index 000000000..b49e6da81
--- /dev/null
+++ b/main/libc0.9.32/0021-libcrypt-add-support-for-SHA256-CRYPT-password-hashi.patch
@@ -0,0 +1,789 @@
+From 243a437f9345fd7182bb4b2f60d892cc86794e8d Mon Sep 17 00:00:00 2001
+From: William Pitcock <nenolod@dereferenced.org>
+Date: Mon, 19 Dec 2011 01:25:09 -0600
+Subject: [PATCH] libcrypt: add support for SHA256-CRYPT password hashing
+
+This is based on Ulrich Drepper's implementation in GLIBC, but hacked up to work
+in uClibc. The differences from the GLIBC version are as follows:
+
+- b64_from_24bit() has been converted into a macro
+- Usage of GLIBC-isms (such as libc_freeres_ptr) have been removed
+
+It is enabled by the UCLIBC_HAS_SHA256_CRYPT_IMPL configuration symbol. You must
+have UCLIBC_HAS_CRYPT_IMPL enabled as well.
+
+Signed-off-by: William Pitcock <nenolod@dereferenced.org>
+Signed-off-by: Bernhard Reutner-Fischer <rep.dot.nop@gmail.com>
+(cherry picked from commit 3ac5fd7ecaeb6721d812c2b93e446bf9a31acdde)
+---
+ extra/Configs/Config.in | 7 +
+ libcrypt/Makefile.in | 1 +
+ libcrypt/crypt.c | 3 +
+ libcrypt/libcrypt.h | 2 +
+ libcrypt/sha256-crypt.c | 326 +++++++++++++++++++++++++++++++++++++++++++++++
+ libcrypt/sha256.c | 294 ++++++++++++++++++++++++++++++++++++++++++
+ libcrypt/sha256.h | 58 +++++++++
+ 7 files changed, 691 insertions(+), 0 deletions(-)
+ create mode 100644 libcrypt/sha256-crypt.c
+ create mode 100644 libcrypt/sha256.c
+ create mode 100644 libcrypt/sha256.h
+
+diff --git a/extra/Configs/Config.in b/extra/Configs/Config.in
+index eec3ee9..66e4efb 100644
+--- a/extra/Configs/Config.in
++++ b/extra/Configs/Config.in
+@@ -1137,6 +1137,13 @@ config UCLIBC_HAS_CRYPT_IMPL
+ help
+ libcrypt contains crypt(), setkey() and encrypt()
+
++config UCLIBC_HAS_SHA256_CRYPT_IMPL
++ bool "libcrypt SHA256 support"
++ depends on UCLIBC_HAS_CRYPT_IMPL
++ help
++ This adds support for SHA256 password hashing via the crypt() function.
++ Say N here if you do not need SHA256 crypt support.
++
+ config UCLIBC_HAS_SHA512_CRYPT_IMPL
+ bool "libcrypt SHA512 support"
+ depends on UCLIBC_HAS_CRYPT_IMPL
+diff --git a/libcrypt/Makefile.in b/libcrypt/Makefile.in
+index 2fceaed..94753f4 100644
+--- a/libcrypt/Makefile.in
++++ b/libcrypt/Makefile.in
+@@ -21,6 +21,7 @@ libcrypt_OUT := $(top_builddir)libcrypt
+
+ libcrypt_SRC-y :=
+ libcrypt_SRC-$(UCLIBC_HAS_CRYPT_IMPL) += crypt.c des.c md5.c
++libcrypt_SRC-$(UCLIBC_HAS_SHA256_CRYPT_IMPL) += sha256.c sha256-crypt.c
+ libcrypt_SRC-$(UCLIBC_HAS_SHA512_CRYPT_IMPL) += sha512.c sha512-crypt.c
+ libcrypt_SRC-$(UCLIBC_HAS_CRYPT_STUB) += crypt_stub.c
+
+diff --git a/libcrypt/crypt.c b/libcrypt/crypt.c
+index b5bf9ee..188a6a0 100644
+--- a/libcrypt/crypt.c
++++ b/libcrypt/crypt.c
+@@ -19,6 +19,9 @@ static const struct {
+ const crypt_impl_f crypt_impl;
+ } crypt_impl_tab[] = {
+ { "$1$", __md5_crypt },
++#ifdef __UCLIBC_HAS_SHA256_CRYPT_IMPL__
++ { "$5$", __sha256_crypt },
++#endif
+ #ifdef __UCLIBC_HAS_SHA512_CRYPT_IMPL__
+ { "$6$", __sha512_crypt },
+ #endif
+diff --git a/libcrypt/libcrypt.h b/libcrypt/libcrypt.h
+index fcad6ae..67733d1 100644
+--- a/libcrypt/libcrypt.h
++++ b/libcrypt/libcrypt.h
+@@ -9,9 +9,11 @@
+ #define __LIBCRYPT_H__
+
+ extern char *__md5_crypt(const unsigned char *pw, const unsigned char *salt) attribute_hidden;
++extern char *__sha256_crypt(const unsigned char *pw, const unsigned char *salt) attribute_hidden;
+ extern char *__sha512_crypt(const unsigned char *pw, const unsigned char *salt) attribute_hidden;
+ extern char *__des_crypt(const unsigned char *pw, const unsigned char *salt) attribute_hidden;
+
++extern char *__sha256_crypt_r (const char *key, const char *salt, char *buffer, int buflen) attribute_hidden;
+ extern char *__sha512_crypt_r (const char *key, const char *salt, char *buffer, int buflen) attribute_hidden;
+
+ /* shut up gcc-4.x signed warnings */
+diff --git a/libcrypt/sha256-crypt.c b/libcrypt/sha256-crypt.c
+new file mode 100644
+index 0000000..4422148
+--- /dev/null
++++ b/libcrypt/sha256-crypt.c
+@@ -0,0 +1,326 @@
++/* One way encryption based on SHA256 sum.
++ Copyright (C) 2007, 2009 Free Software Foundation, Inc.
++ This file is part of the GNU C Library.
++ Contributed by Ulrich Drepper <drepper@redhat.com>, 2007.
++
++ The GNU C Library is free software; you can redistribute it and/or
++ modify it under the terms of the GNU Lesser General Public
++ License as published by the Free Software Foundation; either
++ version 2.1 of the License, or (at your option) any later version.
++
++ The GNU C Library is distributed in the hope that it will be useful,
++ but WITHOUT ANY WARRANTY; without even the implied warranty of
++ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
++ Lesser General Public License for more details.
++
++ You should have received a copy of the GNU Lesser General Public
++ License along with the GNU C Library; if not, write to the Free
++ Software Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
++ 02111-1307 USA. */
++
++#include <assert.h>
++#include <errno.h>
++#include <stdbool.h>
++#include <stdlib.h>
++#include <string.h>
++#include <sys/param.h>
++
++#include "sha256.h"
++#include "libcrypt.h"
++
++/* Define our magic string to mark salt for SHA256 "encryption"
++ replacement. */
++static const char sha256_salt_prefix[] = "$5$";
++
++/* Prefix for optional rounds specification. */
++static const char sha256_rounds_prefix[] = "rounds=";
++
++/* Maximum salt string length. */
++#define SALT_LEN_MAX 16
++/* Default number of rounds if not explicitly specified. */
++#define ROUNDS_DEFAULT 5000
++/* Minimum number of rounds. */
++#define ROUNDS_MIN 1000
++/* Maximum number of rounds. */
++#define ROUNDS_MAX 999999999
++
++/* Table with characters for base64 transformation. */
++static const char b64t[64] =
++"./0123456789ABCDEFGHIJKLMNOPQRSTUVWXYZabcdefghijklmnopqrstuvwxyz";
++
++#define B64_FROM_24BIT(b2, b1, b0, steps) \
++ { \
++ int n = (steps); \
++ unsigned int w = ((b2) << 16) | ((b1) << 8) | (b0); \
++ while (n-- > 0 && buflen > 0) \
++ { \
++ *cp++ = b64t[w & 0x3f]; \
++ --buflen; \
++ w >>= 6; \
++ } \
++ }
++
++char *
++__sha256_crypt_r (const char *key,
++ const char *salt,
++ char *buffer,
++ int buflen)
++{
++ unsigned char alt_result[32]
++ __attribute__ ((__aligned__ (__alignof__ (uint32_t))));
++ unsigned char temp_result[32]
++ __attribute__ ((__aligned__ (__alignof__ (uint32_t))));
++ size_t salt_len;
++ size_t key_len;
++ size_t cnt;
++ char *cp;
++ char *copied_key = NULL;
++ char *copied_salt = NULL;
++ char *p_bytes;
++ char *s_bytes;
++ /* Default number of rounds. */
++ size_t rounds = ROUNDS_DEFAULT;
++ bool rounds_custom = false;
++
++ /* Find beginning of salt string. The prefix should normally always
++ be present. Just in case it is not. */
++ if (strncmp (sha256_salt_prefix, salt, sizeof (sha256_salt_prefix) - 1) == 0)
++ /* Skip salt prefix. */
++ salt += sizeof (sha256_salt_prefix) - 1;
++
++ if (strncmp (salt, sha256_rounds_prefix, sizeof (sha256_rounds_prefix) - 1)
++ == 0)
++ {
++ const char *num = salt + sizeof (sha256_rounds_prefix) - 1;
++ char *endp;
++ unsigned long int srounds = strtoul (num, &endp, 10);
++ if (*endp == '$')
++ {
++ salt = endp + 1;
++ rounds = MAX (ROUNDS_MIN, MIN (srounds, ROUNDS_MAX));
++ rounds_custom = true;
++ }
++ }
++
++ salt_len = MIN (strcspn (salt, "$"), SALT_LEN_MAX);
++ key_len = strlen (key);
++
++ if ((key - (char *) 0) % __alignof__ (uint32_t) != 0)
++ {
++ char *tmp = (char *) alloca (key_len + __alignof__ (uint32_t));
++ key = copied_key =
++ memcpy (tmp + __alignof__ (uint32_t)
++ - (tmp - (char *) 0) % __alignof__ (uint32_t),
++ key, key_len);
++ assert ((key - (char *) 0) % __alignof__ (uint32_t) == 0);
++ }
++
++ if ((salt - (char *) 0) % __alignof__ (uint32_t) != 0)
++ {
++ char *tmp = (char *) alloca (salt_len + __alignof__ (uint32_t));
++ salt = copied_salt =
++ memcpy (tmp + __alignof__ (uint32_t)
++ - (tmp - (char *) 0) % __alignof__ (uint32_t),
++ salt, salt_len);
++ assert ((salt - (char *) 0) % __alignof__ (uint32_t) == 0);
++ }
++
++ struct sha256_ctx ctx;
++ struct sha256_ctx alt_ctx;
++
++ /* Prepare for the real work. */
++ __sha256_init_ctx (&ctx);
++
++ /* Add the key string. */
++ __sha256_process_bytes (key, key_len, &ctx);
++
++ /* The last part is the salt string. This must be at most 16
++ characters and it ends at the first `$' character. */
++ __sha256_process_bytes (salt, salt_len, &ctx);
++
++
++ /* Compute alternate SHA256 sum with input KEY, SALT, and KEY. The
++ final result will be added to the first context. */
++ __sha256_init_ctx (&alt_ctx);
++
++ /* Add key. */
++ __sha256_process_bytes (key, key_len, &alt_ctx);
++
++ /* Add salt. */
++ __sha256_process_bytes (salt, salt_len, &alt_ctx);
++
++ /* Add key again. */
++ __sha256_process_bytes (key, key_len, &alt_ctx);
++
++ /* Now get result of this (32 bytes) and add it to the other
++ context. */
++ __sha256_finish_ctx (&alt_ctx, alt_result);
++
++ /* Add for any character in the key one byte of the alternate sum. */
++ for (cnt = key_len; cnt > 32; cnt -= 32)
++ __sha256_process_bytes (alt_result, 32, &ctx);
++ __sha256_process_bytes (alt_result, cnt, &ctx);
++
++ /* Take the binary representation of the length of the key and for every
++ 1 add the alternate sum, for every 0 the key. */
++ for (cnt = key_len; cnt > 0; cnt >>= 1)
++ if ((cnt & 1) != 0)
++ __sha256_process_bytes (alt_result, 32, &ctx);
++ else
++ __sha256_process_bytes (key, key_len, &ctx);
++
++ /* Create intermediate result. */
++ __sha256_finish_ctx (&ctx, alt_result);
++
++ /* Start computation of P byte sequence. */
++ __sha256_init_ctx (&alt_ctx);
++
++ /* For every character in the password add the entire password. */
++ for (cnt = 0; cnt < key_len; ++cnt)
++ __sha256_process_bytes (key, key_len, &alt_ctx);
++
++ /* Finish the digest. */
++ __sha256_finish_ctx (&alt_ctx, temp_result);
++
++ /* Create byte sequence P. */
++ cp = p_bytes = alloca (key_len);
++ for (cnt = key_len; cnt >= 32; cnt -= 32)
++ cp = mempcpy (cp, temp_result, 32);
++ memcpy (cp, temp_result, cnt);
++
++ /* Start computation of S byte sequence. */
++ __sha256_init_ctx (&alt_ctx);
++
++ /* For every character in the password add the entire password. */
++ for (cnt = 0; cnt < 16 + alt_result[0]; ++cnt)
++ __sha256_process_bytes (salt, salt_len, &alt_ctx);
++
++ /* Finish the digest. */
++ __sha256_finish_ctx (&alt_ctx, temp_result);
++
++ /* Create byte sequence S. */
++ cp = s_bytes = alloca (salt_len);
++ for (cnt = salt_len; cnt >= 32; cnt -= 32)
++ cp = mempcpy (cp, temp_result, 32);
++ memcpy (cp, temp_result, cnt);
++
++ /* Repeatedly run the collected hash value through SHA256 to burn
++ CPU cycles. */
++ for (cnt = 0; cnt < rounds; ++cnt)
++ {
++ /* New context. */
++ __sha256_init_ctx (&ctx);
++
++ /* Add key or last result. */
++ if ((cnt & 1) != 0)
++ __sha256_process_bytes (p_bytes, key_len, &ctx);
++ else
++ __sha256_process_bytes (alt_result, 32, &ctx);
++
++ /* Add salt for numbers not divisible by 3. */
++ if (cnt % 3 != 0)
++ __sha256_process_bytes (s_bytes, salt_len, &ctx);
++
++ /* Add key for numbers not divisible by 7. */
++ if (cnt % 7 != 0)
++ __sha256_process_bytes (p_bytes, key_len, &ctx);
++
++ /* Add key or last result. */
++ if ((cnt & 1) != 0)
++ __sha256_process_bytes (alt_result, 32, &ctx);
++ else
++ __sha256_process_bytes (p_bytes, key_len, &ctx);
++
++ /* Create intermediate result. */
++ __sha256_finish_ctx (&ctx, alt_result);
++ }
++
++ /* Now we can construct the result string. It consists of three
++ parts. */
++ cp = stpncpy (buffer, sha256_salt_prefix, MAX (0, buflen));
++ buflen -= sizeof (sha256_salt_prefix) - 1;
++
++ if (rounds_custom)
++ {
++ int n = snprintf (cp, MAX (0, buflen), "%s%zu$",
++ sha256_rounds_prefix, rounds);
++ cp += n;
++ buflen -= n;
++ }
++
++ cp = stpncpy (cp, salt, MIN ((size_t) MAX (0, buflen), salt_len));
++ buflen -= MIN ((size_t) MAX (0, buflen), salt_len);
++
++ if (buflen > 0)
++ {
++ *cp++ = '$';
++ --buflen;
++ }
++
++ B64_FROM_24BIT (alt_result[0], alt_result[10], alt_result[20], 4);
++ B64_FROM_24BIT (alt_result[21], alt_result[1], alt_result[11], 4);
++ B64_FROM_24BIT (alt_result[12], alt_result[22], alt_result[2], 4);
++ B64_FROM_24BIT (alt_result[3], alt_result[13], alt_result[23], 4);
++ B64_FROM_24BIT (alt_result[24], alt_result[4], alt_result[14], 4);
++ B64_FROM_24BIT (alt_result[15], alt_result[25], alt_result[5], 4);
++ B64_FROM_24BIT (alt_result[6], alt_result[16], alt_result[26], 4);
++ B64_FROM_24BIT (alt_result[27], alt_result[7], alt_result[17], 4);
++ B64_FROM_24BIT (alt_result[18], alt_result[28], alt_result[8], 4);
++ B64_FROM_24BIT (alt_result[9], alt_result[19], alt_result[29], 4);
++ B64_FROM_24BIT (0, alt_result[31], alt_result[30], 3);
++ if (buflen <= 0)
++ {
++ __set_errno (ERANGE);
++ buffer = NULL;
++ }
++ else
++ *cp = '\0'; /* Terminate the string. */
++
++ /* Clear the buffer for the intermediate result so that people
++ attaching to processes or reading core dumps cannot get any
++ information. We do it in this way to clear correct_words[]
++ inside the SHA256 implementation as well. */
++ __sha256_init_ctx (&ctx);
++ __sha256_finish_ctx (&ctx, alt_result);
++ memset (&ctx, '\0', sizeof (ctx));
++ memset (&alt_ctx, '\0', sizeof (alt_ctx));
++
++ memset (temp_result, '\0', sizeof (temp_result));
++ memset (p_bytes, '\0', key_len);
++ memset (s_bytes, '\0', salt_len);
++ if (copied_key != NULL)
++ memset (copied_key, '\0', key_len);
++ if (copied_salt != NULL)
++ memset (copied_salt, '\0', salt_len);
++
++ return buffer;
++}
++
++static char *buffer;
++
++/* This entry point is equivalent to the `crypt' function in Unix
++ libcs. */
++char *
++__sha256_crypt (const unsigned char *key, const unsigned char *salt)
++{
++ /* We don't want to have an arbitrary limit in the size of the
++ password. We can compute an upper bound for the size of the
++ result in advance and so we can prepare the buffer we pass to
++ `sha256_crypt_r'. */
++ static int buflen;
++ int needed = (sizeof (sha256_salt_prefix) - 1
++ + sizeof (sha256_rounds_prefix) + 9 + 1
++ + strlen (salt) + 1 + 43 + 1);
++
++ if (buflen < needed)
++ {
++ char *new_buffer = (char *) realloc (buffer, needed);
++ if (new_buffer == NULL)
++ return NULL;
++
++ buffer = new_buffer;
++ buflen = needed;
++ }
++
++ return __sha256_crypt_r ((const char *) key, (const char *) salt, buffer, buflen);
++}
+diff --git a/libcrypt/sha256.c b/libcrypt/sha256.c
+new file mode 100644
+index 0000000..e652a67
+--- /dev/null
++++ b/libcrypt/sha256.c
+@@ -0,0 +1,294 @@
++/* Functions to compute SHA256 message digest of files or memory blocks.
++ according to the definition of SHA256 in FIPS 180-2.
++ Copyright (C) 2007 Free Software Foundation, Inc.
++ This file is part of the GNU C Library.
++
++ The GNU C Library is free software; you can redistribute it and/or
++ modify it under the terms of the GNU Lesser General Public
++ License as published by the Free Software Foundation; either
++ version 2.1 of the License, or (at your option) any later version.
++
++ The GNU C Library is distributed in the hope that it will be useful,
++ but WITHOUT ANY WARRANTY; without even the implied warranty of
++ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
++ Lesser General Public License for more details.
++
++ You should have received a copy of the GNU Lesser General Public
++ License along with the GNU C Library; if not, write to the Free
++ Software Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
++ 02111-1307 USA. */
++
++/* Written by Ulrich Drepper <drepper@redhat.com>, 2007. */
++
++#ifdef HAVE_CONFIG_H
++# include <config.h>
++#endif
++
++#include <endian.h>
++#include <stdlib.h>
++#include <string.h>
++#include <sys/types.h>
++
++#include "sha256.h"
++
++#if __BYTE_ORDER == __LITTLE_ENDIAN
++# ifdef _LIBC
++# include <byteswap.h>
++# define SWAP(n) bswap_32 (n)
++# else
++# define SWAP(n) \
++ (((n) << 24) | (((n) & 0xff00) << 8) | (((n) >> 8) & 0xff00) | ((n) >> 24))
++# endif
++#else
++# define SWAP(n) (n)
++#endif
++
++
++/* This array contains the bytes used to pad the buffer to the next
++ 64-byte boundary. (FIPS 180-2:5.1.1) */
++static const unsigned char fillbuf[64] = { 0x80, 0 /* , 0, 0, ... */ };
++
++
++/* Constants for SHA256 from FIPS 180-2:4.2.2. */
++static const uint32_t K[64] =
++ {
++ 0x428a2f98, 0x71374491, 0xb5c0fbcf, 0xe9b5dba5,
++ 0x3956c25b, 0x59f111f1, 0x923f82a4, 0xab1c5ed5,
++ 0xd807aa98, 0x12835b01, 0x243185be, 0x550c7dc3,
++ 0x72be5d74, 0x80deb1fe, 0x9bdc06a7, 0xc19bf174,
++ 0xe49b69c1, 0xefbe4786, 0x0fc19dc6, 0x240ca1cc,
++ 0x2de92c6f, 0x4a7484aa, 0x5cb0a9dc, 0x76f988da,
++ 0x983e5152, 0xa831c66d, 0xb00327c8, 0xbf597fc7,
++ 0xc6e00bf3, 0xd5a79147, 0x06ca6351, 0x14292967,
++ 0x27b70a85, 0x2e1b2138, 0x4d2c6dfc, 0x53380d13,
++ 0x650a7354, 0x766a0abb, 0x81c2c92e, 0x92722c85,
++ 0xa2bfe8a1, 0xa81a664b, 0xc24b8b70, 0xc76c51a3,
++ 0xd192e819, 0xd6990624, 0xf40e3585, 0x106aa070,
++ 0x19a4c116, 0x1e376c08, 0x2748774c, 0x34b0bcb5,
++ 0x391c0cb3, 0x4ed8aa4a, 0x5b9cca4f, 0x682e6ff3,
++ 0x748f82ee, 0x78a5636f, 0x84c87814, 0x8cc70208,
++ 0x90befffa, 0xa4506ceb, 0xbef9a3f7, 0xc67178f2
++ };
++
++
++/* Process LEN bytes of BUFFER, accumulating context into CTX.
++ It is assumed that LEN % 64 == 0. */
++static void
++sha256_process_block (const void *buffer, size_t len, struct sha256_ctx *ctx)
++{
++ const uint32_t *words = buffer;
++ size_t nwords = len / sizeof (uint32_t);
++ uint32_t a = ctx->H[0];
++ uint32_t b = ctx->H[1];
++ uint32_t c = ctx->H[2];
++ uint32_t d = ctx->H[3];
++ uint32_t e = ctx->H[4];
++ uint32_t f = ctx->H[5];
++ uint32_t g = ctx->H[6];
++ uint32_t h = ctx->H[7];
++
++ /* First increment the byte count. FIPS 180-2 specifies the possible
++ length of the file up to 2^64 bits. Here we only compute the
++ number of bytes. Do a double word increment. */
++ ctx->total[0] += len;
++ if (ctx->total[0] < len)
++ ++ctx->total[1];
++
++ /* Process all bytes in the buffer with 64 bytes in each round of
++ the loop. */
++ while (nwords > 0)
++ {
++ uint32_t W[64];
++ uint32_t a_save = a;
++ uint32_t b_save = b;
++ uint32_t c_save = c;
++ uint32_t d_save = d;
++ uint32_t e_save = e;
++ uint32_t f_save = f;
++ uint32_t g_save = g;
++ uint32_t h_save = h;
++
++ /* Operators defined in FIPS 180-2:4.1.2. */
++#define Ch(x, y, z) ((x & y) ^ (~x & z))
++#define Maj(x, y, z) ((x & y) ^ (x & z) ^ (y & z))
++#define S0(x) (CYCLIC (x, 2) ^ CYCLIC (x, 13) ^ CYCLIC (x, 22))
++#define S1(x) (CYCLIC (x, 6) ^ CYCLIC (x, 11) ^ CYCLIC (x, 25))
++#define R0(x) (CYCLIC (x, 7) ^ CYCLIC (x, 18) ^ (x >> 3))
++#define R1(x) (CYCLIC (x, 17) ^ CYCLIC (x, 19) ^ (x >> 10))
++
++ /* It is unfortunate that C does not provide an operator for
++ cyclic rotation. Hope the C compiler is smart enough. */
++#define CYCLIC(w, s) ((w >> s) | (w << (32 - s)))
++
++ /* Compute the message schedule according to FIPS 180-2:6.2.2 step 2. */
++ for (unsigned int t = 0; t < 16; ++t)
++ {
++ W[t] = SWAP (*words);
++ ++words;
++ }
++ for (unsigned int t = 16; t < 64; ++t)
++ W[t] = R1 (W[t - 2]) + W[t - 7] + R0 (W[t - 15]) + W[t - 16];
++
++ /* The actual computation according to FIPS 180-2:6.2.2 step 3. */
++ for (unsigned int t = 0; t < 64; ++t)
++ {
++ uint32_t T1 = h + S1 (e) + Ch (e, f, g) + K[t] + W[t];
++ uint32_t T2 = S0 (a) + Maj (a, b, c);
++ h = g;
++ g = f;
++ f = e;
++ e = d + T1;
++ d = c;
++ c = b;
++ b = a;
++ a = T1 + T2;
++ }
++
++ /* Add the starting values of the context according to FIPS 180-2:6.2.2
++ step 4. */
++ a += a_save;
++ b += b_save;
++ c += c_save;
++ d += d_save;
++ e += e_save;
++ f += f_save;
++ g += g_save;
++ h += h_save;
++
++ /* Prepare for the next round. */
++ nwords -= 16;
++ }
++
++ /* Put checksum in context given as argument. */
++ ctx->H[0] = a;
++ ctx->H[1] = b;
++ ctx->H[2] = c;
++ ctx->H[3] = d;
++ ctx->H[4] = e;
++ ctx->H[5] = f;
++ ctx->H[6] = g;
++ ctx->H[7] = h;
++}
++
++
++/* Initialize structure containing state of computation.
++ (FIPS 180-2:5.3.2) */
++void
++__sha256_init_ctx (struct sha256_ctx *ctx)
++{
++ ctx->H[0] = 0x6a09e667;
++ ctx->H[1] = 0xbb67ae85;
++ ctx->H[2] = 0x3c6ef372;
++ ctx->H[3] = 0xa54ff53a;
++ ctx->H[4] = 0x510e527f;
++ ctx->H[5] = 0x9b05688c;
++ ctx->H[6] = 0x1f83d9ab;
++ ctx->H[7] = 0x5be0cd19;
++
++ ctx->total[0] = ctx->total[1] = 0;
++ ctx->buflen = 0;
++}
++
++
++/* Process the remaining bytes in the internal buffer and the usual
++ prolog according to the standard and write the result to RESBUF.
++
++ IMPORTANT: On some systems it is required that RESBUF is correctly
++ aligned for a 32 bits value. */
++void *
++__sha256_finish_ctx (struct sha256_ctx *ctx, void *resbuf)
++{
++ /* Take yet unprocessed bytes into account. */
++ uint32_t bytes = ctx->buflen;
++ size_t pad;
++
++ /* Now count remaining bytes. */
++ ctx->total[0] += bytes;
++ if (ctx->total[0] < bytes)
++ ++ctx->total[1];
++
++ pad = bytes >= 56 ? 64 + 56 - bytes : 56 - bytes;
++ memcpy (&ctx->buffer[bytes], fillbuf, pad);
++
++ /* Put the 64-bit file length in *bits* at the end of the buffer. */
++ *(uint32_t *) &ctx->buffer[bytes + pad + 4] = SWAP (ctx->total[0] << 3);
++ *(uint32_t *) &ctx->buffer[bytes + pad] = SWAP ((ctx->total[1] << 3) |
++ (ctx->total[0] >> 29));
++
++ /* Process last bytes. */
++ sha256_process_block (ctx->buffer, bytes + pad + 8, ctx);
++
++ /* Put result from CTX in first 32 bytes following RESBUF. */
++ for (unsigned int i = 0; i < 8; ++i)
++ ((uint32_t *) resbuf)[i] = SWAP (ctx->H[i]);
++
++ return resbuf;
++}
++
++
++void
++__sha256_process_bytes (const void *buffer, size_t len, struct sha256_ctx *ctx)
++{
++ /* When we already have some bits in our internal buffer concatenate
++ both inputs first. */
++ if (ctx->buflen != 0)
++ {
++ size_t left_over = ctx->buflen;
++ size_t add = 128 - left_over > len ? len : 128 - left_over;
++
++ memcpy (&ctx->buffer[left_over], buffer, add);
++ ctx->buflen += add;
++
++ if (ctx->buflen > 64)
++ {
++ sha256_process_block (ctx->buffer, ctx->buflen & ~63, ctx);
++
++ ctx->buflen &= 63;
++ /* The regions in the following copy operation cannot overlap. */
++ memcpy (ctx->buffer, &ctx->buffer[(left_over + add) & ~63],
++ ctx->buflen);
++ }
++
++ buffer = (const char *) buffer + add;
++ len -= add;
++ }
++
++ /* Process available complete blocks. */
++ if (len >= 64)
++ {
++#if __GNUC__ >= 2
++# define UNALIGNED_P(p) (((uintptr_t) p) % __alignof__ (uint32_t) != 0)
++#else
++# define UNALIGNED_P(p) (((uintptr_t) p) % sizeof (uint32_t) != 0)
++#endif
++ if (UNALIGNED_P (buffer))
++ while (len > 64)
++ {
++ sha256_process_block (memcpy (ctx->buffer, buffer, 64), 64, ctx);
++ buffer = (const char *) buffer + 64;
++ len -= 64;
++ }
++ else
++ {
++ sha256_process_block (buffer, len & ~63, ctx);
++ buffer = (const char *) buffer + (len & ~63);
++ len &= 63;
++ }
++ }
++
++ /* Move remaining bytes into internal buffer. */
++ if (len > 0)
++ {
++ size_t left_over = ctx->buflen;
++
++ memcpy (&ctx->buffer[left_over], buffer, len);
++ left_over += len;
++ if (left_over >= 64)
++ {
++ sha256_process_block (ctx->buffer, 64, ctx);
++ left_over -= 64;
++ memcpy (ctx->buffer, &ctx->buffer[64], left_over);
++ }
++ ctx->buflen = left_over;
++ }
++}
+diff --git a/libcrypt/sha256.h b/libcrypt/sha256.h
+new file mode 100644
+index 0000000..291674f
+--- /dev/null
++++ b/libcrypt/sha256.h
+@@ -0,0 +1,58 @@
++/* Declaration of functions and data types used for SHA256 sum computing
++ library functions.
++ Copyright (C) 2007 Free Software Foundation, Inc.
++ This file is part of the GNU C Library.
++
++ The GNU C Library is free software; you can redistribute it and/or
++ modify it under the terms of the GNU Lesser General Public
++ License as published by the Free Software Foundation; either
++ version 2.1 of the License, or (at your option) any later version.
++
++ The GNU C Library is distributed in the hope that it will be useful,
++ but WITHOUT ANY WARRANTY; without even the implied warranty of
++ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
++ Lesser General Public License for more details.
++
++ You should have received a copy of the GNU Lesser General Public
++ License along with the GNU C Library; if not, write to the Free
++ Software Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
++ 02111-1307 USA. */
++
++#ifndef _SHA256_H
++#define _SHA256_H 1
++
++#include <limits.h>
++#include <stdint.h>
++#include <stdio.h>
++
++
++/* Structure to save state of computation between the single steps. */
++struct sha256_ctx
++{
++ uint32_t H[8];
++
++ uint32_t total[2];
++ uint32_t buflen;
++ char buffer[128] __attribute__ ((__aligned__ (__alignof__ (uint32_t))));
++};
++
++/* Initialize structure containing state of computation.
++ (FIPS 180-2: 5.3.2) */
++extern void __sha256_init_ctx (struct sha256_ctx *ctx) attribute_hidden;
++
++/* Starting with the result of former calls of this function (or the
++ initialization function update the context for the next LEN bytes
++ starting at BUFFER.
++ It is NOT required that LEN is a multiple of 64. */
++extern void __sha256_process_bytes (const void *buffer, size_t len,
++ struct sha256_ctx *ctx) attribute_hidden;
++
++/* Process the remaining bytes in the buffer and put result from CTX
++ in first 32 bytes following RESBUF.
++
++ IMPORTANT: On some systems it is required that RESBUF is correctly
++ aligned for a 32 bits value. */
++extern void *__sha256_finish_ctx (struct sha256_ctx *ctx, void *resbuf)
++ attribute_hidden;
++
++#endif /* sha256.h */
+--
+1.7.8
+