summaryrefslogtreecommitdiffstats
path: root/main/librsync/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/librsync/APKBUILD')
-rw-r--r--main/librsync/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/main/librsync/APKBUILD b/main/librsync/APKBUILD
new file mode 100644
index 000000000..248cda5c9
--- /dev/null
+++ b/main/librsync/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Jeremy Thomerson <jeremy@thomersonfamily.com>
+# Maintainer: Jeremy Thomerson <jeremy@thomersonfamily.com>
+pkgname=librsync
+pkgver=0.9.7
+pkgrel=0
+pkgdesc="librsync implements the rolling-checksum algorithm of rsync"
+url="http://sourceforge.net/projects/librsync/"
+arch="all"
+license="LGPL 2.1"
+depends=""
+makedepends=""
+install=
+subpackages="$pkgname-dev"
+source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+
+build() {
+ cd "$_builddir"
+
+ ./configure --prefix=/usr --mandir=/usr/share/man --enable-shared
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="24cdb6b78f45e0e83766903fd4f6bc84 librsync-0.9.7.tar.gz"