summaryrefslogtreecommitdiffstats
path: root/main/libtheora/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/libtheora/APKBUILD')
-rw-r--r--main/libtheora/APKBUILD31
1 files changed, 23 insertions, 8 deletions
diff --git a/main/libtheora/APKBUILD b/main/libtheora/APKBUILD
index 700a7c79f..f306c0581 100644
--- a/main/libtheora/APKBUILD
+++ b/main/libtheora/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libtheora
pkgver=1.1.1
-pkgrel=4
+pkgrel=5
pkgdesc="An open video codec developed by the Xiph.org"
url="http://www.xiph.org"
license="custom"
@@ -9,23 +9,37 @@ subpackages="$pkgname-dev $pkgname-doc $pkgname-examples"
depends=
makedepends="libvorbis-dev libogg-dev sdl-dev autoconf automake libtool"
source="http://downloads.xiph.org/releases/theora/$pkgname-$pkgver.tar.bz2
- libtheora-flags.patch"
+ libtheora-flags.patch
+ enc.patch
+ "
depends_dev="libogg-dev"
-build() {
- cd "$srcdir"/libtheora-$pkgver
- patch -p1 -i ../libtheora-flags.patch || return 1
+_builddir="$srcdir"/libtheora-$pkgver
+prepare() {
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch)
+ msg "Applying $i"
+ patch -p1 -i "$srcdir"/$i || return 1
+ esac
+ done
aclocal -I m4 && autoconf && automake && libtoolize || return 1
+}
+build() {
+ cd "$_builddir"
./configure --prefix=/usr \
--enable-shared \
--disable-static || return 1
+ cd lib && make || return 1
+ cd ..
make || return 1
}
package() {
- cd "$srcdir"/libtheora-$pkgver
+ cd "$_builddir"
make DESTDIR="$pkgdir" install || return 1
install -m755 -d ""$pkgdir"/usr/share/licenses/$pkgname"
install -m644 LICENSE COPYING "$pkgdir"/usr/share/licenses/$pkgname/
@@ -33,11 +47,12 @@ package() {
examples() {
pkgdesc="Example applications for libtheora"
- cd "$srcdir"/libtheora-$pkgver/examples
+ cd "$_builddir"/examples
install -d "$subpkgdir"/usr/bin
install -m755 dump_psnr player_example dump_video encoder_example \
"$subpkgdir"/usr/bin/
}
md5sums="292ab65cedd5021d6b7ddd117e07cd8e libtheora-1.1.1.tar.bz2
-7cbab1ce1f52adb98e1c241515a27aca libtheora-flags.patch"
+7cbab1ce1f52adb98e1c241515a27aca libtheora-flags.patch
+5024b6c41351433bf0e8a354969f8efd enc.patch"