summaryrefslogtreecommitdiffstats
path: root/main/patch/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'main/patch/APKBUILD')
-rw-r--r--main/patch/APKBUILD21
1 files changed, 21 insertions, 0 deletions
diff --git a/main/patch/APKBUILD b/main/patch/APKBUILD
new file mode 100644
index 000000000..8e4691db7
--- /dev/null
+++ b/main/patch/APKBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=patch
+pkgver=2.5.9
+pkgrel=0
+pkgdesc="Utility to apply diffs to files"
+url="http://www.gnu.org/software/patch/patch.html"
+license='GPL'
+depends=
+source=http://alpha.gnu.org/gnu/diffutils/$pkgname-$pkgver.tar.gz
+
+subpackages="$pkgname-doc"
+
+build() {
+ cd "$srcdir"/$pkgname-$pkgver
+ ./configure --prefix=/usr \
+ --mandir=/usr/share/man
+ make || return 1
+ make prefix="$pkgdir"/usr mandir="$pkgdir"/usr/share/man install
+}
+
+md5sums='dacfb618082f8d3a2194601193cf8716 patch-2.5.9.tar.gz'