summaryrefslogtreecommitdiffstats
path: root/main/x264
diff options
context:
space:
mode:
Diffstat (limited to 'main/x264')
-rw-r--r--main/x264/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/main/x264/APKBUILD b/main/x264/APKBUILD
new file mode 100644
index 000000000..2429f146b
--- /dev/null
+++ b/main/x264/APKBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=x264
+pkgver=20100107
+pkgrel=0
+pkgdesc="free library for encoding H264/AVC video streams"
+url="http://www.videolan.org/developers/x264.html"
+license="GPL"
+depends=
+makedepends="libx11-dev bash"
+subpackages="$pkgname-dev"
+source="http://ftp.videolan.org/pub/videolan/$pkgname/snapshots/$pkgname-snapshot-$pkgver-2245.tar.bz2"
+
+_builddir="$srcdir/$pkgname-snapshot-$pkgver-2245"
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --enable-pthread \
+ --enable-visualize \
+ --enable-shared \
+ --disable-asm \
+ --enable-pic || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" bindir=/usr/bin libdir=/usr/lib includedir=/usr/include install || return 1
+}
+md5sums="58337bf425518cb79dd804bcfd10b7b7 x264-snapshot-20100107-2245.tar.bz2"