summaryrefslogtreecommitdiffstats
path: root/testing/apache-mod-auth-kerb/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/apache-mod-auth-kerb/APKBUILD')
-rw-r--r--testing/apache-mod-auth-kerb/APKBUILD45
1 files changed, 45 insertions, 0 deletions
diff --git a/testing/apache-mod-auth-kerb/APKBUILD b/testing/apache-mod-auth-kerb/APKBUILD
new file mode 100644
index 000000000..16bc7fb2e
--- /dev/null
+++ b/testing/apache-mod-auth-kerb/APKBUILD
@@ -0,0 +1,45 @@
+# Contributor: Francesco Colista <francesco.colista@gmail.com>
+# Maintainer: Francesco Colista <francesco.colista@gmail.com>
+pkgname=apache-mod-auth-kerb
+_pkgname=mod_auth_kerb
+pkgver=5.4
+pkgrel=0
+pkgdesc="A Kerberos authentication module for the Apache Http Server"
+url="http://samba.org/ftp/unpacked/lorikeet/mod_auth_ntlm_winbind/"
+arch="x86 x86_64"
+license="custom"
+depends="apache2 heimdal"
+makedepends="apache2-dev heimdal-dev samba-dev bash"
+source="http://downloads.sourceforge.net/project/modauthkerb/$_pkgname/$_pkgname-$pkgver/$_pkgname-$pkgver.tar.gz
+ mod_auth_kerb.patch
+ mod-auth-kerb.conf
+ "
+prepare() {
+ cd $srcdir/$_pkgname-$pkgver
+ for i in "$srcdir"/*.patch; do
+ [ -f "$i" ] || continue
+ msg "Applying $i"
+ patch -p1 -i $i || return 1
+ done
+ sed -i -e 's:^ret.*:ret=`eval "$4" $5 $cppflags $ldflags src/mod_auth_kerb.c $3`:' apxs.sh
+}
+
+build() {
+ cd $srcdir/$_pkgname-$pkgver
+ ./configure --prefix=/usr \
+ --with-krb5=/usr
+ make -j6 || return 1
+}
+
+package() {
+ cd $srcdir/$_pkgname-$pkgver
+# make DESTDIR="$pkgdir" install || return 1
+ mkdir -p "$pkgdir"/etc/apache2/conf.d
+ mkdir -p "$pkgdir"/usr/lib/apache2
+ install -D -m755 ./src/.libs/*.so "$pkgdir"/usr/lib/apache2
+ install -D -m644 ../../mod-auth-kerb.conf "$pkgdir"/etc/apache2/conf.d/mod-auth-kerb.conf
+}
+
+md5sums="642b81763ad3ca81dba359cb952da5e3 mod_auth_kerb-5.4.tar.gz
+3ef3cd9c723f34a2ee7ab350b7c653c9 mod_auth_kerb.patch
+7f9a0976ff101226fae4fd9b811b21a4 mod-auth-kerb.conf"